summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-08-31 11:19:43 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-08-31 11:20:19 +0900
commit9350101fe3e6c017f6cb301181263f7c48fdb048 (patch)
treec923c5ee7f629513416fae041eb870134ba6208a /dev-python/jupyter_client
parentmedia-libs/openh264-1.7.0: alpha stable, bug 604420 (diff)
downloadgentoo-9350101fe3e6c017f6cb301181263f7c48fdb048.tar.gz
gentoo-9350101fe3e6c017f6cb301181263f7c48fdb048.tar.bz2
gentoo-9350101fe3e6c017f6cb301181263f7c48fdb048.zip
dev-python/jupyter_client: include the missing patch.
Credit: Harris Landgarten Bug: 629376 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch b/dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch
new file mode 100644
index 000000000000..ff7dcb0f3d4c
--- /dev/null
+++ b/dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch
@@ -0,0 +1,39 @@
+From f9bd2643d42b3354b27e64368d8c15cad18101d2 Mon Sep 17 00:00:00 2001
+From: Philipp A <flying-sheep@web.de>
+Date: Tue, 8 Aug 2017 17:38:52 +0200
+Subject: [PATCH] Always use setuptools if availabe
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+When running `python* setup.py install`, the `jupyter-run` script doesn’t get installed without this.
+---
+ setup.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 60fa17c..0831f7a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -70,6 +70,7 @@
+ ],
+ )
+
++# require setuptools for these cases
+ if 'develop' in sys.argv or any(a.startswith('bdist') for a in sys.argv):
+ import setuptools
+
+@@ -85,7 +86,12 @@
+ 'test': ['ipykernel', 'ipython', 'mock', 'pytest'],
+ }
+
+-if 'setuptools' in sys.modules:
++# always try to use setuptools if available
++try:
++ import setuptools
++except ImportError:
++ pass
++else:
+ setup_args.update(setuptools_args)
+ setup_args['entry_points'] = {
+ 'console_scripts': [