summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-bibtex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-bibtex')
-rw-r--r--dev-python/python-bibtex/Manifest1
-rw-r--r--dev-python/python-bibtex/files/python-bibtex-1.2.4-fix_tests.patch28
-rw-r--r--dev-python/python-bibtex/metadata.xml9
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild35
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/python-bibtex/Manifest b/dev-python/python-bibtex/Manifest
new file mode 100644
index 000000000000..66f08d15fb53
--- /dev/null
+++ b/dev-python/python-bibtex/Manifest
@@ -0,0 +1 @@
+DIST python-bibtex-1.2.7.tar.gz 60894 SHA256 37709a19b94858def4ede028e670b14153f98c62c6adc926af8102a3279eeaf0 SHA512 6739824fcdad91e2abb333d9e17a31bd222e6100630b8e4f65a9e718d36eb451600fdc7380cb63b89c4a33a7554b79dd1c52448d19c3359f21deee2134242e6b WHIRLPOOL 9c067e05473da5ec7ac5b6a0e5e5dc1363326aeff38946bef33858df8cc324079bf82bed59c5a7642310b749fcd9a8b62f341256373fcefe6919d54dae1fd034
diff --git a/dev-python/python-bibtex/files/python-bibtex-1.2.4-fix_tests.patch b/dev-python/python-bibtex/files/python-bibtex-1.2.4-fix_tests.patch
new file mode 100644
index 000000000000..f9816817b777
--- /dev/null
+++ b/dev-python/python-bibtex/files/python-bibtex-1.2.4-fix_tests.patch
@@ -0,0 +1,28 @@
+--- testsuite.py
++++ testsuite.py
+@@ -4,6 +4,7 @@
+
+ import sys, os
+
++ParserError = "ParserError"
+
+ def check_recode ():
+ try:
+@@ -65,7 +66,7 @@
+
+ valid = result.readline ().strip ()
+
+- if obtained != valid:
++ if eval(obtained) != eval(valid):
+ sys.stderr.write ('error: %s: line %d: unexpected result:\n' % (
+ filename, line))
+ sys.stderr.write ('error: %s: line %d: obtained %s\n' % (
+@@ -117,7 +118,7 @@
+
+ valid = result.readline ().strip ()
+
+- if obtained != valid:
++ if eval(obtained) != eval(valid):
+ sys.stderr.write ('error: %s: line %d: unexpected result:\n' % (
+ filename, line))
+ sys.stderr.write ('error: %s: line %d: obtained %s\n' % (
diff --git a/dev-python/python-bibtex/metadata.xml b/dev-python/python-bibtex/metadata.xml
new file mode 100644
index 000000000000..98ccc2e27a99
--- /dev/null
+++ b/dev-python/python-bibtex/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">pybliographer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..a0d367fc8202
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python extension to parse BibTeX files"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=app-text/recode-3.6-r1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # Disable tests during installation.
+ sed -e "/self.run_command ('check')/d" -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py check
+}