summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-18 16:17:53 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-18 16:37:40 +0200
commit877c739695b3b8fdb1579a6cf3b52df18089aba9 (patch)
treeb508ea326f79c1f2deb56c63977dc3378925d907 /dev-python/python-magic/python-magic-0.4.15.ebuild
parentsys-apps/file: Enable py3.7 (diff)
downloadgentoo-877c739695b3b8fdb1579a6cf3b52df18089aba9.tar.gz
gentoo-877c739695b3b8fdb1579a6cf3b52df18089aba9.tar.bz2
gentoo-877c739695b3b8fdb1579a6cf3b52df18089aba9.zip
dev-python/python-magic: Actually run tests
Actually run the tests from the package rather than CPython's own test suite. Closes: https://bugs.gentoo.org/659102
Diffstat (limited to 'dev-python/python-magic/python-magic-0.4.15.ebuild')
-rw-r--r--dev-python/python-magic/python-magic-0.4.15.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/python-magic/python-magic-0.4.15.ebuild b/dev-python/python-magic/python-magic-0.4.15.ebuild
index 272c99c42619..1abf74ba9369 100644
--- a/dev-python/python-magic/python-magic-0.4.15.ebuild
+++ b/dev-python/python-magic/python-magic-0.4.15.ebuild
@@ -9,7 +9,7 @@ inherit distutils-r1
DESCRIPTION="Access the libmagic file type identification library"
HOMEPAGE="https://github.com/ahupp/python-magic"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ahupp/python-magic/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -20,9 +20,6 @@ RDEPEND="sys-apps/file[-python]"
DEPEND="${DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
-# Needs MacOS python module, bug #659102
-RESTRICT="test"
-
python_test() {
- esetup.py test
+ "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
}