summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-24 15:25:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-24 15:26:52 +0200
commit30a3377250635ec38eb8d0a2bdc4dbe37398722d (patch)
treec66c4e0e191d33fda6ae9510f4692fe40066dd62 /dev-python/rst-linker
parentdev-python/jaraco-vcs: New package, v2.1.0 (diff)
downloadgentoo-30a3377250635ec38eb8d0a2bdc4dbe37398722d.tar.gz
gentoo-30a3377250635ec38eb8d0a2bdc4dbe37398722d.tar.bz2
gentoo-30a3377250635ec38eb8d0a2bdc4dbe37398722d.zip
dev-python/rst-linker: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rst-linker')
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-2.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index 3dbe53e3f09f..84cca2993867 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1,2 +1,3 @@
DIST rst.linker-2.4.0.tar.gz 11340 BLAKE2B a1ae9c811b7d6fa2821bfbf5787dce75fd3d7e5d933ec15fbac9cd3bde08cfad59fdc81b3b58dc39d1209a27ca9dd8d2ecd68034b434b3f6d15469bfb98efa3d SHA512 31e3427ecf35b433cc9650138ee36090e99003b72c69b60b530835eb624d7eb13aae4cf81cc0044b36750798a4b8aa676e53e3b9eb335430076593640a243940
DIST rst_linker-2.5.0.tar.gz 11548 BLAKE2B eafa6a0076dd51d05779710cb3b41f4b6e5109b25ea71537bc4f4e75d8c0fe4c9329321833e5a9253bb4a51fab706488a78ece4679a4c52cd7fc0295cc29e76f SHA512 7aaa55ccbe34767f8c0e085703872f4112c5db142e81f7024fd0653fa74fcf0b9d15fec06998268e8161dc70dac6935ba7b380992a132ecaa2548ed0db3b5a13
+DIST rst_linker-2.6.0.tar.gz 11308 BLAKE2B 216c3d79b2de02fc53f1548127d7dc08d85d065e103659168b6e4b9521d75972f1ff28c78b45f59a9be09c16e66897c2506b0e48d37b3a08b114060999a76d09 SHA512 08977a88e53ebdb82f0e69923430e08a9ad643c184ad76154a7d5840c8193e71e53fd1b7fb97f6d74f65d55e3d45f5c0c262a60a1d030788d2c067f71918aa8e
diff --git a/dev-python/rst-linker/rst-linker-2.6.0.ebuild b/dev-python/rst-linker/rst-linker-2.6.0.ebuild
new file mode 100644
index 000000000000..714e2cf969fd
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="
+ https://github.com/jaraco/rst.linker/
+ https://pypi.org/project/rst.linker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-vcs-2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pytest-subprocess[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest