summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-19 10:29:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-19 10:36:14 +0200
commit7ae1e9ffd38be099ec9ec9144fdf28c0a917bd98 (patch)
tree229165fa8020dc8cf4bf37a7c848b2d384d1a810 /dev-python/toolz
parentdev-python/vobject: Remove old (diff)
downloadgentoo-7ae1e9ffd38be099ec9ec9144fdf28c0a917bd98.tar.gz
gentoo-7ae1e9ffd38be099ec9ec9144fdf28c0a917bd98.tar.bz2
gentoo-7ae1e9ffd38be099ec9ec9144fdf28c0a917bd98.zip
dev-python/toolz: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toolz')
-rw-r--r--dev-python/toolz/Manifest1
-rw-r--r--dev-python/toolz/files/toolz-0.12.1-test.patch88
-rw-r--r--dev-python/toolz/toolz-0.12.1.ebuild31
3 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/toolz/Manifest b/dev-python/toolz/Manifest
index 0b2556cae946..18748254a05f 100644
--- a/dev-python/toolz/Manifest
+++ b/dev-python/toolz/Manifest
@@ -1,2 +1 @@
-DIST toolz-0.12.1.tar.gz 66550 BLAKE2B 41b2002147cd453c2a8300c7ec247e06dfc8fba69a772df4a8f5c35349e991453bbbd0d7ed0162391d9314873bf0e169d20c86b875e4d4eca01aaadc76edea61 SHA512 c514934d1a8069cd70e4d8b9ca32cd2c96e85b1dabb45bbbe4b0644581eb7e7f9f6a6d9230483f1872695edf25ff77ad7643cffb3041a012ed64424097a23e9e
DIST toolz-1.0.0.tar.gz 66790 BLAKE2B c5e6d8bb96561f7ca97ac7b3a8233eb1002892974c7dd4127732a89117608dfa964ec9d8ab1f8f679e487885b76d4eaed33be275a90afa4beb4a21e1ce4f29ab SHA512 90ba917ff06b7c4a4bbeb1d2c64bcb34bbe41607c7cea402f9d96f352c20c53edc53333ba06da9193bc714a2a836e68acd55e581b9f590fe1d962fc4ae8847d9
diff --git a/dev-python/toolz/files/toolz-0.12.1-test.patch b/dev-python/toolz/files/toolz-0.12.1-test.patch
deleted file mode 100644
index 396ed003a62e..000000000000
--- a/dev-python/toolz/files/toolz-0.12.1-test.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From b79a954ca5fa6801c3a3dc6b39fa523be33884a8 Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Fri, 14 Jun 2024 13:43:24 -0700
-Subject: [PATCH 1/2] test_excepts: fudge changed indentation in Python 3.13
-
-Signed-off-by: Adam Williamson <awilliam@redhat.com>
----
- toolz/tests/test_functoolz.py | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/toolz/tests/test_functoolz.py b/toolz/tests/test_functoolz.py
-index 555cf48d..a28c2a77 100644
---- a/toolz/tests/test_functoolz.py
-+++ b/toolz/tests/test_functoolz.py
-@@ -738,10 +738,13 @@ def f(a, b):
- def test_excepts():
- # These are descriptors, make sure this works correctly.
- assert excepts.__name__ == 'excepts'
-+ # in Python < 3.13 the second line is indented, in 3.13+
-+ # it is not, strip all lines to fudge it
-+ testlines = "\n".join((line.strip() for line in excepts.__doc__.splitlines()))
- assert (
- 'A wrapper around a function to catch exceptions and\n'
-- ' dispatch to a handler.\n'
-- ) in excepts.__doc__
-+ 'dispatch to a handler.\n'
-+ ) in testlines
-
- def idx(a):
- """idx docstring
-
-From 832e81d28882d1235c704de95e1d075ee61976c1 Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Fri, 14 Jun 2024 16:03:30 -0700
-Subject: [PATCH 2/2] test_inspect_wrapped_property: handle fixed wrapper
- inspection
-
-Python upstream recently fixed the behavior of inspect with
-wrappers: https://github.com/python/cpython/issues/112006 . The
-assertion here relies on the broken behavior, we only get None
-if `inspect(Wrapped)` fails and raises `ValueError`. Now it
-works, we actually get the correct answer, 1. This changes it so
-we assert the correct thing depending on the Python version (the
-fix was backported to 3.11.9 and 3.12.3, so the check has to be a
-bit complicated).
-
-Signed-off-by: Adam Williamson <awilliam@redhat.com>
----
- toolz/tests/test_inspect_args.py | 21 +++++++++++++++++++--
- 1 file changed, 19 insertions(+), 2 deletions(-)
-
-diff --git a/toolz/tests/test_inspect_args.py b/toolz/tests/test_inspect_args.py
-index 93408eb5..f26dbc64 100644
---- a/toolz/tests/test_inspect_args.py
-+++ b/toolz/tests/test_inspect_args.py
-@@ -2,6 +2,7 @@
- import inspect
- import itertools
- import operator
-+import sys
- import toolz
- from toolz.functoolz import (curry, is_valid_args, is_partial_args, is_arity,
- num_required_args, has_varargs, has_keywords)
-@@ -482,6 +483,22 @@ def __wrapped__(self):
- wrapped = Wrapped(func)
- assert inspect.signature(func) == inspect.signature(wrapped)
-
-- assert num_required_args(Wrapped) is None
-- _sigs.signatures[Wrapped] = (_sigs.expand_sig((0, lambda func: None)),)
-+ # inspect.signature did not used to work properly on wrappers,
-+ # but it was fixed in Python 3.11.9, Python 3.12.3 and Python
-+ # 3.13+
-+ inspectbroken = True
-+ if sys.version_info.major > 3:
-+ inspectbroken = False
-+ if sys.version_info.major == 3:
-+ if sys.version_info.minor == 11 and sys.version_info.micro > 8:
-+ inspectbroken = False
-+ if sys.version_info.minor == 12 and sys.version_info.micro > 2:
-+ inspectbroken = False
-+ if sys.version_info.minor > 12:
-+ inspectbroken = False
-+
-+ if inspectbroken:
-+ assert num_required_args(Wrapped) is None
-+ _sigs.signatures[Wrapped] = (_sigs.expand_sig((0, lambda func: None)),)
-+
- assert num_required_args(Wrapped) == 1
diff --git a/dev-python/toolz/toolz-0.12.1.ebuild b/dev-python/toolz/toolz-0.12.1.ebuild
deleted file mode 100644
index ed5ce6e423ee..000000000000
--- a/dev-python/toolz/toolz-0.12.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="List processing tools and functional utilities"
-HOMEPAGE="
- https://github.com/pytoolz/toolz/
- https://pypi.org/project/toolz/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pytoolz/toolz/pull/582
- "${FILESDIR}/${P}-test.patch"
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}