summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-25 05:04:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-25 05:47:51 +0100
commit322933f25f6fa1e2982d6d1dab3aa1422e82e037 (patch)
tree0d94cc373c4fc5d50fb32375839d20c302f39145 /dev-python
parentdev-python/pyupgrade: Bump to 3.15.2 (diff)
downloadgentoo-322933f25f6fa1e2982d6d1dab3aa1422e82e037.tar.gz
gentoo-322933f25f6fa1e2982d6d1dab3aa1422e82e037.tar.bz2
gentoo-322933f25f6fa1e2982d6d1dab3aa1422e82e037.zip
dev-python/rapidfuzz: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 853553bfcd59..b0cf7aee165f 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1 +1,2 @@
DIST rapidfuzz-3.6.2.tar.gz 1556623 BLAKE2B aef59f1d03309535015e0fb27688613630c0e2c459f464223d4ef8dbbb0241f991ae2b9c9d81890f7cd063f33ad7e6193a6f9c98c5287010402b402e1f343b1e SHA512 83ba27ec1c68d10c568ee629519709113aac3136e73da55d46dcfd3b0f1eac2ebe8631376ca10d2b5fde892d690d79f5a8ce5fd0114502d1f3576756b0960db7
+DIST rapidfuzz-3.7.0.tar.gz 1569549 BLAKE2B fca22e86c002eeef7763487168d072941bbaefc7fa9cb9d5ae3d3f49e3a4487d69917da6663436cfc73ca38c67f2fc3a985e82dd64fe430aabc3708efada8513 SHA512 058fee9dc4d6934bf7b0e10eb8cc39303b6b4b67562c3b2244ec9035b1d5c3301aaf1570aa26099a6f3a6c0e7b52c387a01fcd62be28f55ab755377d053eb7f5
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild
new file mode 100644
index 000000000000..07d8d11d86eb
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/rapidfuzz/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-3.0.2
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+ # remove bundled libraries
+ rm -r extern || die
+ # force recythonization
+ find src -name '*.cxx' -delete || die
+
+ distutils-r1_src_prepare
+
+ export RAPIDFUZZ_BUILD_EXTENSION=1
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # scikit-build is broken and reuses the same build
+ # https://github.com/scikit-build/scikit-build/issues/633
+ rm -r _skbuild || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}