summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-26 06:56:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-26 07:36:40 +0200
commit5e7e6054e8158ef0ee5663a46086db2d684e7ad6 (patch)
treed9e7950b41fd314d48478ce3e1761b821707fa82 /dev-python
parentdev-python/hypothesis: Bump to 6.72.4 (diff)
downloadgentoo-5e7e6054e8158ef0ee5663a46086db2d684e7ad6.tar.gz
gentoo-5e7e6054e8158ef0ee5663a46086db2d684e7ad6.tar.bz2
gentoo-5e7e6054e8158ef0ee5663a46086db2d684e7ad6.zip
dev-python/pyupgrade: Bump to 3.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.3.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index a71a06294e2b..428e1727f844 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1 +1,2 @@
DIST pyupgrade-3.3.1.gh.tar.gz 62720 BLAKE2B e1b1d899bb46871f0a28ac3423efbcbd91e0bbdac2ab3054fc19434c67a8702e4967d3cd7674284022e7b7847dc947c8d1736eeee78d8a9416de2b7c25eae715 SHA512 1f062a884061e77ec11e6dd1cc1bedd2680b443b1268b30a9f6bfa2954ef3ff8a6dd1108abdb3a9b0acc937456fe6621a5ad3b9e9ad5c1696e95d0903859ff5f
+DIST pyupgrade-3.3.2.gh.tar.gz 62698 BLAKE2B 5dc1d9e9ea7b91cb2835ffdbc109fb4fcde629f375c49714cf52fe779b20a61f38f13321a14803636e759ac8a4460e768c4173c6608da1cf7cd44a3a347660e9 SHA512 6436286a9398d9cae8c5e9cff2104c43638cafb866a1b97794c1d20cadc078ae5a657d1b83512461d20d2f581b8f8fbbb2ee4d0516f8e75d562c5934be4966e5
diff --git a/dev-python/pyupgrade/pyupgrade-3.3.2.ebuild b/dev-python/pyupgrade/pyupgrade-3.3.2.ebuild
new file mode 100644
index 000000000000..e9dec0883fc1
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/tokenize-rt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest