summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-18 22:18:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-18 22:40:26 +0200
commit85280555110c6af14a7203e499faea081375a901 (patch)
tree57471c2a01e6ef65cdc2e4d0e3dc8be280786f65 /dev-python
parentdev-python/pycares: Bump to 4.1.2 (diff)
downloadgentoo-85280555110c6af14a7203e499faea081375a901.tar.gz
gentoo-85280555110c6af14a7203e499faea081375a901.tar.bz2
gentoo-85280555110c6af14a7203e499faea081375a901.zip
dev-python/hypothesis: Bump to 6.23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.23.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 7041b0bd4f78..8ed7dcbdf49e 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.22.0.tar.gz 9166539 BLAKE2B 386c7fd4f9ff0d4d199f686f257
DIST hypothesis-python-6.23.0.tar.gz 9166945 BLAKE2B 89d8a642262dfcbd36d83343c5e632653808711e186f5afae360e870eaacf050b415fd1abeb589b375136f273a53a236da8e4ab6227d94e16c58c8e9d0d3d8a9 SHA512 43d5f1a21d555e2a7942414cfb185e9201d9c5198c12551db7a50f3f118fed4dddc934767a0e7d880dfd044ac1a062b64afc92c5c3f391cedf71b829e177f21d
DIST hypothesis-python-6.23.1.tar.gz 9167114 BLAKE2B 324df90b9fc09dbaf599905b503119eed22ad32898d118d08cb5a84cbb3a514d0bfea51eca0c9878f3a330702d4822c5c311e9c6e091a6baed51285d8d326c5e SHA512 2d6a10ef6b47e0bc08c90aee62a9f009c5bfe7d64bc6f87fed72232c40a43b86e0ecc744527a611f3cfec571051c4bef3986c4e1970f92526e70bf7f5e523519
DIST hypothesis-python-6.23.2.tar.gz 9167318 BLAKE2B 0a1ccf0235c64dd69705e48f67c132021898a024e8ae035d2ffc8a416c45443931ffff4a67a13f1c1ee7bbc2201e6f4ca5363568f0ed2ea4743ae46569e45ef1 SHA512 704b8d8c15e1fd510206c8d07f6a0f0bc81249bbc036978e4864e8ce234e35bab89069b0d5a0e958c57fe31fdb63fcc454502ac633d6fd986aaea9841383f36b
+DIST hypothesis-python-6.23.3.tar.gz 9167498 BLAKE2B 04d0111d7ff5516ed25c9dc9e8c9793489b5fbf009688bf97a0c7f84ea241bcb0112eb57ba177a7bf23944e7288b0694a3db0f01b5357901b34eea86c5cf67c2 SHA512 9212076c61175960fd638b9b75b8a0f51b75969c93c6b5b2aedacadfc08860931b8f1bfad21b34ca34c0ee64609b34b3027342bbf093aa0e5c304706f081f60a
diff --git a/dev-python/hypothesis/hypothesis-6.23.3.ebuild b/dev-python/hypothesis/hypothesis-6.23.3.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.23.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}