summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-07 06:17:53 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-07 06:25:11 +0100
commite0f2d69143b2a84afbf2ae0c861ad273d6a7790e (patch)
treee5fbc35cb44a9508f65b5c0d537f2793b0a524c0 /dev-python
parentdev-python/qiskit-aer: Bump to 0.16.1 (diff)
downloadgentoo-e0f2d69143b2a84afbf2ae0c861ad273d6a7790e.tar.gz
gentoo-e0f2d69143b2a84afbf2ae0c861ad273d6a7790e.tar.bz2
gentoo-e0f2d69143b2a84afbf2ae0c861ad273d6a7790e.zip
dev-python/x-wr-timezone: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/x-wr-timezone/Manifest1
-rw-r--r--dev-python/x-wr-timezone/x-wr-timezone-2.0.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/x-wr-timezone/Manifest b/dev-python/x-wr-timezone/Manifest
index 1296194aada7..6402b0cbbd0f 100644
--- a/dev-python/x-wr-timezone/Manifest
+++ b/dev-python/x-wr-timezone/Manifest
@@ -1,2 +1,3 @@
DIST x-wr-timezone-1.0.1.gh.tar.gz 22182 BLAKE2B 18ac9281b484de7eb1b4da9063743b98b63e259f7ad914c68194d49e27aa3528f0466e6e7c6c668e14e58ef1439f2c8db6bb8b8f94e51635a63f13af98db826b SHA512 4c388efc2b5710f5db24de218d72ef4ddfd951186fa67631a34f48d49ffcd391195f0232104c586eeae18fb414eab61b3bb1f52d39416c2123eb452a44f20ad6
DIST x-wr-timezone-2.0.0.gh.tar.gz 23131 BLAKE2B 878615167c145a139892bbb651697b05707a8e05ff62e578118a40b773299f4eb356b04d3de34387ea20cfdb230179d8b9d48abc1a8e6a0e90d138d028669c7c SHA512 c42b71d9bf08e3395121ef32b4a015404824e74c0b9731d80f94c8cfa10efe9a1259413faa6bf3d33ac44f3aaf24e28a5bbc23259cb532e7ec44654951dc9081
+DIST x-wr-timezone-2.0.1.gh.tar.gz 23799 BLAKE2B 32a7599657a06f164fac6f245beb0fce5d2d16b9ec3188c7273812f49143b215cf779573ca03016160af417b86a80a4f61e1aca5fb184f6511bac4c6746ca85c SHA512 ceb20827e9204b05566102d9dd8ef214d1507338e95d00509f9aeaa0f43faada880a46ad7e88f88ee24dce705d7adbc7a0759fd733fb90fa8d8a232e7080606f
diff --git a/dev-python/x-wr-timezone/x-wr-timezone-2.0.1.ebuild b/dev-python/x-wr-timezone/x-wr-timezone-2.0.1.ebuild
new file mode 100644
index 000000000000..458433076a32
--- /dev/null
+++ b/dev-python/x-wr-timezone/x-wr-timezone-2.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert calendars using X-WR-TIMEZONE to standard ones"
+HOMEPAGE="
+ https://github.com/niccokunzmann/x-wr-timezone/
+ https://pypi.org/project/x-wr-timezone/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/x-wr-timezone/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-6.1.0[${PYTHON_USEDEP}]
+ dev-python/tzdata[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-click[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)