summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-31 12:12:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:09 -0400
commitb678646b21b85905bfc5b206c6b5ae65942f9e1b (patch)
treed7ebfc581f6c36950fc8a3e2fa797af55a8e47e9 /dev-qt/qtbase
parentdev-qt/qtbase: workaround for cmake zstd support for now (diff)
downloadgentoo-b678646b21b85905bfc5b206c6b5ae65942f9e1b.tar.gz
gentoo-b678646b21b85905bfc5b206c6b5ae65942f9e1b.tar.bz2
gentoo-b678646b21b85905bfc5b206c6b5ae65942f9e1b.zip
dev-qt/qtbase: skip known broken tests with musl
May potentially be indicating real issues, but revdeps still pass tests (even qtwebengine, or well, when patched to build with musl) and, similarly to x86, just going to skip to have a baseline. Not personally going too deep into musl issues (not using it). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtbase')
-rw-r--r--dev-qt/qtbase/qtbase-6.5.2-r1.ebuild9
-rw-r--r--dev-qt/qtbase/qtbase-6.5.9999.ebuild9
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild9
3 files changed, 27 insertions, 0 deletions
diff --git a/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild b/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild
index 14358b97ce1a..1ba39adc5821 100644
--- a/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild
@@ -256,6 +256,15 @@ src_test() {
tst_qglyphrun
tst_qvectornd
tst_rcc
+ # partially broken on llvm-musl, needs looking into but skip to have
+ # a baseline for regressions (like above, rest of dev-qt is fine)
+ $(usev elibc_musl '
+ tst_qfiledialog2
+ tst_qicoimageformat
+ tst_qimagereader
+ tst_qpainter
+ tst_qimage
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)
diff --git a/dev-qt/qtbase/qtbase-6.5.9999.ebuild b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
index 312f14d0805d..adcefddc36ca 100644
--- a/dev-qt/qtbase/qtbase-6.5.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
@@ -251,6 +251,15 @@ src_test() {
tst_qglyphrun
tst_qvectornd
tst_rcc
+ # partially broken on llvm-musl, needs looking into but skip to have
+ # a baseline for regressions (like above, rest of dev-qt is fine)
+ $(usev elibc_musl '
+ tst_qfiledialog2
+ tst_qicoimageformat
+ tst_qimagereader
+ tst_qpainter
+ tst_qimage
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 312f14d0805d..adcefddc36ca 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -251,6 +251,15 @@ src_test() {
tst_qglyphrun
tst_qvectornd
tst_rcc
+ # partially broken on llvm-musl, needs looking into but skip to have
+ # a baseline for regressions (like above, rest of dev-qt is fine)
+ $(usev elibc_musl '
+ tst_qfiledialog2
+ tst_qicoimageformat
+ tst_qimagereader
+ tst_qpainter
+ tst_qimage
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)