summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-08-13 04:36:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-08-13 04:37:23 +1000
commit24262cbec6f03a03d69e5855b7b2bfe764646972 (patch)
treeb78d6761588d442e0d2abc893f66098b4a5d9691 /dev-qt/qtscxml
parentprofiles: mask Qt 5.7.0 for wider testing (diff)
downloadgentoo-24262cbec6f03a03d69e5855b7b2bfe764646972.tar.gz
gentoo-24262cbec6f03a03d69e5855b7b2bfe764646972.tar.bz2
gentoo-24262cbec6f03a03d69e5855b7b2bfe764646972.zip
dev-qt: version bump 5.7.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/metadata.xml17
-rw-r--r--dev-qt/qtscxml/qtscxml-5.7.0.ebuild20
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
new file mode 100644
index 000000000000..5243e3d17f8d
--- /dev/null
+++ b/dev-qt/qtscxml/Manifest
@@ -0,0 +1 @@
+DIST qtscxml-opensource-src-5.7.0.tar.xz 346120 SHA256 370b13d76c9a2ddf05336e797edf7f54d41db6063e3b921e0825dd6dd26c51f1 SHA512 08429391ecca88910d8b4982e28d049066d73d5c7db03b125f32b060194168795c92f7a04516ca969383f1ee381cf9de655eca34494d283b9bbbcefdb7391305 WHIRLPOOL bd3ce464b2f80774ccd508058fb3bf01c25099e63e36a05fb45a50bbed1b24ca66d53d5e53a46a8b9521a6d7d30f4ed251a60983b9347b7906e0ead90e62364b
diff --git a/dev-qt/qtscxml/metadata.xml b/dev-qt/qtscxml/metadata.xml
new file mode 100644
index 000000000000..08d85fc4c258
--- /dev/null
+++ b/dev-qt/qtscxml/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
+</pkgmetadata>
diff --git a/dev-qt/qtscxml/qtscxml-5.7.0.ebuild b/dev-qt/qtscxml/qtscxml-5.7.0.ebuild
new file mode 100644
index 000000000000..ee21ba458fde
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-5.7.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+"
+RDEPEND="${DEPEND}"