summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 00:49:11 +0000
committerSam James <sam@gentoo.org>2024-02-29 00:49:11 +0000
commit622845d1dd47fce41f4b3b5794346eb4815f43b3 (patch)
treec531fbc4da115815508ab3b082ee72fc8be2fa78 /dev-ruby/coolio
parentdev-perl/EV: filter LTO, no-SA (diff)
downloadgentoo-622845d1dd47fce41f4b3b5794346eb4815f43b3.tar.gz
gentoo-622845d1dd47fce41f4b3b5794346eb4815f43b3.tar.bz2
gentoo-622845d1dd47fce41f4b3b5794346eb4815f43b3.zip
dev-ruby/coolio: filter LTO, no-SA
Broken quite badly via bundled liebv, no upstream bug tracker for libev AFAICT. And broken in many bundled copies all over the place (which are modified...) Closes: https://bugs.gentoo.org/857603 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/coolio')
-rw-r--r--dev-ruby/coolio/coolio-1.7.1-r1.ebuild8
-rw-r--r--dev-ruby/coolio/coolio-1.7.1-r2.ebuild8
-rw-r--r--dev-ruby/coolio/coolio-1.8.0.ebuild8
3 files changed, 18 insertions, 6 deletions
diff --git a/dev-ruby/coolio/coolio-1.7.1-r1.ebuild b/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
index ce243d72a5a8..030b833390e9 100644
--- a/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
+++ b/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
RUBY_FAKEGEM_EXTENSIONS=(ext/cool.io/extconf.rb ext/iobuffer/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
HOMEPAGE="https://coolio.github.io/"
@@ -26,6 +26,10 @@ IUSE=""
# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
rm -r Gemfile* lib/.gitignore || die
sed -i -e '/[Bb]undler/d' Rakefile || die
diff --git a/dev-ruby/coolio/coolio-1.7.1-r2.ebuild b/dev-ruby/coolio/coolio-1.7.1-r2.ebuild
index 538c9aad48f1..1dda791d8c93 100644
--- a/dev-ruby/coolio/coolio-1.7.1-r2.ebuild
+++ b/dev-ruby/coolio/coolio-1.7.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
RUBY_FAKEGEM_EXTENSIONS=(ext/cool.io/extconf.rb ext/iobuffer/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
HOMEPAGE="https://coolio.github.io/"
@@ -30,6 +30,10 @@ PATCHES=(
# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
rm -r Gemfile* lib/.gitignore || die
sed -i -e '/[Bb]undler/d' Rakefile || die
diff --git a/dev-ruby/coolio/coolio-1.8.0.ebuild b/dev-ruby/coolio/coolio-1.8.0.ebuild
index 89809568f100..d521e9ab6350 100644
--- a/dev-ruby/coolio/coolio-1.8.0.ebuild
+++ b/dev-ruby/coolio/coolio-1.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
RUBY_FAKEGEM_EXTENSIONS=(ext/cool.io/extconf.rb ext/iobuffer/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
HOMEPAGE="https://coolio.github.io/"
@@ -26,6 +26,10 @@ IUSE=""
# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
rm -r Gemfile* lib/.gitignore || die
sed -i -e '/[Bb]undler/d' Rakefile || die