summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 02:18:18 +0100
committerSam James <sam@gentoo.org>2023-03-29 13:56:14 +0100
commitddf7c7fabbb6fdda9fbf1e627adfa1689fb589a9 (patch)
tree51094bbd1994378bd1cd666ad7a574fa60a00b3a /dev-ruby/json
parentdev-ruby/rexical: drop 1.0.7 (diff)
downloadgentoo-ddf7c7fabbb6fdda9fbf1e627adfa1689fb589a9.tar.gz
gentoo-ddf7c7fabbb6fdda9fbf1e627adfa1689fb589a9.tar.bz2
gentoo-ddf7c7fabbb6fdda9fbf1e627adfa1689fb589a9.zip
dev-ruby/json: drop 2.5.1-r1, 2.6.1, 2.6.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/Manifest3
-rw-r--r--dev-ruby/json/json-2.5.1-r1.ebuild63
-rw-r--r--dev-ruby/json/json-2.6.1.ebuild63
-rw-r--r--dev-ruby/json/json-2.6.2.ebuild50
4 files changed, 0 insertions, 179 deletions
diff --git a/dev-ruby/json/Manifest b/dev-ruby/json/Manifest
index 08f1aae1e2e1..b4f91805013a 100644
--- a/dev-ruby/json/Manifest
+++ b/dev-ruby/json/Manifest
@@ -1,4 +1 @@
-DIST json-2.5.1.tar.gz 131183 BLAKE2B 2ccdf5921ef476b66cb1dbf72cc01763636c82b0eb5d0a5cfc029e14177c7c6766464e7852b11c2424db401f5b931cb64c01d3952929236c9979378a7928ea59 SHA512 4df7ec9b86692376e89c2019c2c1ab3ae9af28fb4742864acc6f985c0551fc10795742cc1124d6435e820617c00d4c5f4aa6c83b21d2fff43ed05cd9d0a89087
-DIST json-2.6.1.tar.gz 132705 BLAKE2B 5a8e83b8d11e360402324427de5d2520f39ee1567e2fbf3c92c738546792bb5dec4a9a3c36f3286a3de63161bb5d9f9e7b059c2560f7a3fa50271ce2aa3dc0fc SHA512 e9d0ef77d77ae54a0300b490e3e5c445d0b5aefbce1b160454916bd4f4f8f943131223047e6a7416347cc40d9e7fb1870101c3cbf3a2663a9053f07bdfbd13cf
-DIST json-2.6.2.tar.gz 133073 BLAKE2B f81202ee284d3a6afe5c6f3ddccde76655e170b64883e37bc38c47bd63d731f8dca4e8a57da15e275ad64af5e1e967def69590d1105c0069b92f322919782a84 SHA512 9c1c16ef462e7736c0306781573f32b96a0a53368ed24b4d1ae97953df62956b6cd72dcd20ed07708b0e1e3dd71baa61551bde452c87d7efac41267c0ee60b33
DIST json-2.6.3.tar.gz 133077 BLAKE2B f6101f533159fb689b6bf22975137d34a77bd0926c164a9c14f2d5eab982778538ec40551709e8a6470f05e78584a3e5680be740314bb7829b48feb32fb258ae SHA512 1bf9125266d8cdc565deb9e2fe3c884a1fc8d2f3b31caae67a154d0c47e30305074c1c08b49d180dd785c766762b46d3b3ef85919d53388797fcc2f37675317c
diff --git a/dev-ruby/json/json-2.5.1-r1.ebuild b/dev-ruby/json/json-2.5.1-r1.ebuild
deleted file mode 100644
index ec077cbe9732..000000000000
--- a/dev-ruby/json/json-2.5.1-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/json/ext/parser/extconf.rb ext/json/ext/generator/extconf.rb)
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( BSD-2 Ruby )"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e '/task :test/ s|:compile,||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-
- # Remove hardcoded and broken -O setting.
- sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
- -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-
- # Avoid setting gem since it will not be available yet when installing
- sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
-}
-
-#each_ruby_compile() {
-# for ext in parser generator ; do
-# cp ext/json/ext/${ext}/${ext}$(get_modname) ext/json/ext/ || die
-# done
-#}
-
-each_ruby_install() {
- each_fakegem_install
-
- #ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- #ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
-}
diff --git a/dev-ruby/json/json-2.6.1.ebuild b/dev-ruby/json/json-2.6.1.ebuild
deleted file mode 100644
index a90b9af04b1f..000000000000
--- a/dev-ruby/json/json-2.6.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/json/ext/parser/extconf.rb ext/json/ext/generator/extconf.rb)
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( BSD-2 Ruby )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e '/task :test/ s|:compile,||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-
- # Remove hardcoded and broken -O setting.
- sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
- -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-
- # Avoid setting gem since it will not be available yet when installing
- sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
-}
-
-#each_ruby_compile() {
-# for ext in parser generator ; do
-# cp ext/json/ext/${ext}/${ext}$(get_modname) ext/json/ext/ || die
-# done
-#}
-
-each_ruby_install() {
- each_fakegem_install
-
- #ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- #ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
-}
diff --git a/dev-ruby/json/json-2.6.2.ebuild b/dev-ruby/json/json-2.6.2.ebuild
deleted file mode 100644
index 1cdeaa8478c9..000000000000
--- a/dev-ruby/json/json-2.6.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/json/ext/parser/extconf.rb ext/json/ext/generator/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( BSD-2 Ruby )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e '/task :test/ s|:compile,||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-
- # Remove hardcoded and broken -O setting.
- sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
- -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-
- # Avoid setting gem since it will not be available yet when installing
- sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
-}