summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-21 07:22:08 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-21 07:22:08 +0100
commit25c719035381c388b35bc15a5c02fd414bfd5ce2 (patch)
tree23fbb94b8cc681e47248330f461eb8284dc59416 /dev-ruby/simplecov/simplecov-0.14.1.ebuild
parentdev-ruby/ox: add 2.4.11 (diff)
downloadgentoo-25c719035381c388b35bc15a5c02fd414bfd5ce2.tar.gz
gentoo-25c719035381c388b35bc15a5c02fd414bfd5ce2.tar.bz2
gentoo-25c719035381c388b35bc15a5c02fd414bfd5ce2.zip
dev-ruby/simplecov: add 0.14.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.14.1.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.14.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.14.1.ebuild b/dev-ruby/simplecov/simplecov-0.14.1.ebuild
new file mode 100644
index 000000000000..ec401c929eae
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.14.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and merging across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/json-1.8:0 <dev-ruby/json-3:0
+ dev-ruby/simplecov-html:0.10
+ >=dev-ruby/docile-1.1.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/test-unit:2
+)"
+
+# There are also cucumber tests that require poltergeist and unpackaged phantomjs gem.
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/helper.rb features/support/env.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
+
+ #${RUBY} -S cucumber features || die
+}