summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-09 16:05:17 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-09 20:25:47 +0200
commitc6f1b54c987f245d2c9a6dc9357313eb8e968267 (patch)
tree22a77896e123f8c3108d4dc4367767e025f4a85b /dev-ruby/tilt
parentdev-python/werkzeug: Stabilize 2.3.6 ppc64, #910161 (diff)
downloadgentoo-c6f1b54c987f245d2c9a6dc9357313eb8e968267.tar.gz
gentoo-c6f1b54c987f245d2c9a6dc9357313eb8e968267.tar.bz2
gentoo-c6f1b54c987f245d2c9a6dc9357313eb8e968267.zip
dev-ruby/tilt: add 2.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index f31a652a34a5..121a3ff5e552 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,2 +1,3 @@
DIST tilt-2.0.11.tar.gz 53041 BLAKE2B 2509cc3efe5e6302c8943c00108eeda6ee4b23a18952ad23049e11ea28b397b80a21d34c4d241119f45cedf2a978a2673d857a6cc32d7e26a2016caa510458f9 SHA512 e28e31ab92aa42eada34e0f6c05dab6a54945d07b649588356b1635ba8a36700f6e537e8702613883693501442d21690d8b3690b06f7b9f331192134511b78b7
DIST tilt-2.1.0.tar.gz 54542 BLAKE2B b2d7729654efb51d9f61afe75476d6620edd7c104c045dc68c6a5e983cea8dec612d2e5013c51ee7736c87d770acdf8e6f186ff156d177f3281e0fb58d0e8422 SHA512 a450bdc51d782169cda2c43b550fad1425d4ee1a8f3c2da0bb1112051eb9ccfd95e903984ed6d3c76b0f322a243021587c6614f6452c385450ff1a985cfbcaa5
+DIST tilt-2.2.0.tar.gz 57826 BLAKE2B 10729ac9cb2e2d0b2292a6fdacc0d705179d719d7f4bbdb11075e0eeaeb82933daec22063d3448ea2ada6e50f37b2b66303854707f50162efd11a6151ded45df SHA512 135a32402512fda71952dc2534b02a291d749dbdcb9e17f52c7fa6ecfe3bd7e894f28f3d3d4a595daa63ffbe90cca106347aa916541292558a26d8122fcd7c90
diff --git a/dev-ruby/tilt/tilt-2.2.0.ebuild b/dev-ruby/tilt/tilt-2.2.0.ebuild
new file mode 100644
index 000000000000..200a882f0d0c
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/jeremyevans/tilt"
+SRC_URI="https://github.com/jeremyevans/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to facilitate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubi
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+ sed -e '7irequire "uri"' -i test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ rm -f test/tilt_sasstemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}