summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-01-19 19:26:29 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-01-19 19:28:59 +0300
commitc2b8ac714bdf2d8087c5307f8824928179ca02da (patch)
treee8686a0f3fe01ab6f37d90106f33167fef2ba30f /dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild
parentdev-util/meson: improve comment regarding "1 boost" test (diff)
downloadgentoo-c2b8ac714bdf2d8087c5307f8824928179ca02da.tar.gz
gentoo-c2b8ac714bdf2d8087c5307f8824928179ca02da.tar.bz2
gentoo-c2b8ac714bdf2d8087c5307f8824928179ca02da.zip
dev-tex/pdfannotextractor: port to EAPI=7
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild')
-rw-r--r--dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild31
1 files changed, 10 insertions, 21 deletions
diff --git a/dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild b/dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild
index e33d504b94fc..1b6371bf6dbe 100644
--- a/dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild
+++ b/dev-tex/pdfannotextractor/pdfannotextractor-0.1l-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit latex-package java-pkg-2 java-ant-2 eutils
+inherit latex-package java-pkg-2 java-ant-2
DESCRIPTION="Extract annotations from pdf files"
HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/pax/"
@@ -12,23 +12,23 @@ SRC_URI="mirror://gentoo/${P}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ppc64 x86 ~x64-macos"
-IUSE=""
-CDEPEND="virtual/latex-base
+COMMON_DEPEND="virtual/latex-base
dev-java/pdfbox:1.8
dev-java/fontbox:1.7"
-DEPEND="${CDEPEND}
- app-arch/unzip
+DEPEND="${COMMON_DEPEND}
>=virtual/jdk-1.6"
-RDEPEND="${CDEPEND}
+BDEPEND="app-arch/unzip"
+
+RDEPEND="${COMMIN_DEPEND}
virtual/perl-Getopt-Long
dev-perl/File-Which
- >=virtual/jre-1.6
- !<=dev-texlive/texlive-latexextra-2010"
+ >=virtual/jre-1.6"
TEXMF=/usr/share/texmf-site
+
S="${WORKDIR}"
JAVA_ANT_REWRITE_CLASSPATH="true"
@@ -37,17 +37,6 @@ EANT_GENTOO_CLASSPATH="
fontbox-1.7
"
-PATCHES=(
- "${FILESDIR}/javajars.patch"
- "${FILESDIR}/PDFAnnotExtractor.java.patch"
- "${FILESDIR}/StringVisitor.java.patch"
-)
-
-java_prepare() {
- java-pkg_clean
- epatch "${PATCHES[@]}"
-}
-
src_compile() {
cd "${S}/source/latex/pax" || die
eant || die