summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/cvsspam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/cvsspam')
-rw-r--r--dev-vcs/cvsspam/Manifest1
-rw-r--r--dev-vcs/cvsspam/cvsspam-0.2.12.ebuild35
-rw-r--r--dev-vcs/cvsspam/files/cvsspam-0.2.12-svn.patch30
-rw-r--r--dev-vcs/cvsspam/metadata.xml7
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-vcs/cvsspam/Manifest b/dev-vcs/cvsspam/Manifest
new file mode 100644
index 000000000000..fa998c728188
--- /dev/null
+++ b/dev-vcs/cvsspam/Manifest
@@ -0,0 +1 @@
+DIST cvsspam-0.2.12.tar.gz 83714 SHA256 217c53ceebcc7fcbb8949304648b48c7c0805e0c4531d0c85473e8dd685b3e16 SHA512 80786f980fe5070fff90de8e7a470cdf91ee8ddbd4c37fb1d98d0ddc042d157f2f74998962eaab1a24503b9147fae2129db35f1d505b557a8c75325d1e101bec WHIRLPOOL f59677098ab67d7b558e1de0eb6f6e361dad0505873c96701bc8ab4da3b93871dc80405764d2083ab7d346cbbf058b136dacea8081413a7ec8fb12bc1e88843f
diff --git a/dev-vcs/cvsspam/cvsspam-0.2.12.ebuild b/dev-vcs/cvsspam/cvsspam-0.2.12.ebuild
new file mode 100644
index 000000000000..fda4d9005d1d
--- /dev/null
+++ b/dev-vcs/cvsspam/cvsspam-0.2.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Utility to send colored HTML CVS-mails"
+HOMEPAGE="http://www.badgers-in-foil.co.uk/projects/cvsspam/"
+SRC_URI="http://www.badgers-in-foil.co.uk/projects/cvsspam/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="subversion"
+
+RDEPEND="dev-lang/ruby
+ subversion? ( dev-vcs/subversion )
+"
+
+src_prepare() {
+ use subversion && epatch "${FILESDIR}/${P}-svn.patch"
+}
+
+src_install() {
+ dobin collect_diffs.rb
+ dobin cvsspam.rb
+ dobin record_lastdir.rb
+ insinto /etc/cvsspam
+ doins cvsspam.conf
+
+ dohtml cvsspam-doc.html
+ dodoc CREDITS TODO cvsspam-doc.pdf
+}
diff --git a/dev-vcs/cvsspam/files/cvsspam-0.2.12-svn.patch b/dev-vcs/cvsspam/files/cvsspam-0.2.12-svn.patch
new file mode 100644
index 000000000000..3278f94bc005
--- /dev/null
+++ b/dev-vcs/cvsspam/files/cvsspam-0.2.12-svn.patch
@@ -0,0 +1,30 @@
+--- cvsspam.rb.old 2006-12-02 13:36:48.000000000 -0500
++++ cvsspam.rb 2006-12-02 13:38:28.000000000 -0500
+@@ -1386,12 +1386,10 @@
+ $allTags = Hash.new
+
+ File.open("#{$logfile}.emailtmp", File::RDWR|File::CREAT|File::TRUNC) do |mail|
++ reader = LogReader.new($stdin)
+
+ $diff_output_limiter = OutputSizeLimiter.new(mail, $mail_size_limit)
+
+- File.open($logfile) do |log|
+- reader = LogReader.new(log)
+-
+ until reader.eof
+ handler = $handlers[reader.currentLineCode]
+ if handler == nil
+@@ -1399,12 +1397,11 @@
+ end
+ handler.handleLines(reader.getLines, $diff_output_limiter)
+ end
+- end
+
+ end
+
+ if $subjectPrefix == nil
+- $subjectPrefix = "[CVS #{Repository.array.join(',')}]"
++ $subjectPrefix = "[SVN #{Repository.array.join(',')}]"
+ end
+
+ if $files_in_subject
diff --git a/dev-vcs/cvsspam/metadata.xml b/dev-vcs/cvsspam/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/dev-vcs/cvsspam/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>