summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-11 13:25:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-11 14:24:04 +0200
commita54b4512d5ade8a5488a17b1b8d0160c206c60b5 (patch)
tree48f8806d0529f719d0254e655b62c05b18148f20 /dev-vcs
parentdev-python/libcloud: Bump to 3.6.1 (diff)
downloadgentoo-a54b4512d5ade8a5488a17b1b8d0160c206c60b5.tar.gz
gentoo-a54b4512d5ade8a5488a17b1b8d0160c206c60b5.tar.bz2
gentoo-a54b4512d5ade8a5488a17b1b8d0160c206c60b5.zip
dev-vcs/git-filter-repo: Bump to 2.38.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-filter-repo/Manifest1
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/git-filter-repo/Manifest b/dev-vcs/git-filter-repo/Manifest
index a8328ea84074..ad47baf83932 100644
--- a/dev-vcs/git-filter-repo/Manifest
+++ b/dev-vcs/git-filter-repo/Manifest
@@ -1,2 +1,3 @@
DIST git-filter-repo-2.33.0.tar.xz 148024 BLAKE2B d23b47575cad60db2c42fe794d6b648ee14b0c126cc832b267030e6c8b4edb0acd6fe7e2666da086b3c79184a7e4362b585dfab8966102552f8317e3027d5d32 SHA512 9a4fc3e95c9b6bd399925bb8554acf93711a015756cc826a9f9ed06e91538addb78b3120876c46af4245892adfca7428d915a33d6d2890d9c0196cef5d4faa0f
DIST git-filter-repo-2.34.0.tar.xz 149112 BLAKE2B 7b9316fe4ee07ce996e92977947f64f753296b681f7a6ad32610b6478af637f558aa0eb2294a5066b09c8e654f279c2c22358f36ce12d2869f7874f36bbf1df5 SHA512 debd638f22d3543607b3d26dbdca867975ce2fd2ce03d4088e4e1d4e1be1db4655aeb8ef9de5b3930df4006511653e0b517646d1be51ab55807d19f404e14450
+DIST git-filter-repo-2.38.0.tar.xz 153772 BLAKE2B 491269226c5db9fa57bb5e2038e2c8cb3e82577ff1ba8b34920857c2ec4275d4491e8e17f5bd34e63148ae0d6f7bb57ab3d1d36ffecd390579e0fdc773046d71 SHA512 786c27c1952a5e3625c924e71958cfd61d9065d32754a3e957f258767ccb5b147778c5d499eb82c7c1bf36a2f5a50b1cde372ebbc927aeeedbd713e5ab6563d8
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild
new file mode 100644
index 000000000000..f51f33fa7528
--- /dev/null
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-single-r1
+
+DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
+HOMEPAGE="https://github.com/newren/git-filter-repo/"
+SRC_URI="
+ https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-vcs/git-2.24.0
+"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ bash t/run_tests || die
+}
+
+src_install() {
+ python_fix_shebang git-filter-repo
+ dobin git-filter-repo
+ doman Documentation/man1/git-filter-repo.1
+}