summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/mt_gtk_client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/mt_gtk_client')
-rw-r--r--games-board/mt_gtk_client/Manifest1
-rw-r--r--games-board/mt_gtk_client/metadata.xml5
-rw-r--r--games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild36
3 files changed, 42 insertions, 0 deletions
diff --git a/games-board/mt_gtk_client/Manifest b/games-board/mt_gtk_client/Manifest
new file mode 100644
index 000000000000..bc1c2f0affef
--- /dev/null
+++ b/games-board/mt_gtk_client/Manifest
@@ -0,0 +1 @@
+DIST mt_gtk_client-0.1.98.tar.bz2 181458 SHA256 094539edc591d470a85f742fabf077f1054ae0362424899a1da25cde48f2de16 SHA512 8d43baf29a100b37db0f4f8b3f417c8253b6c243b7ead18efefbc3706361fbc652abf808c0b104dec5573a769eaa2d84903ad0ab602c738c139c86b8c36bf401 WHIRLPOOL 18f9517a0f733adebee601a2015ff1d40a2bda34fc8ff61f74c547106f3b545efa1646684341e26076f53b1f44fdae734baadb040d5f4a35b82c1c89a22e22ac
diff --git a/games-board/mt_gtk_client/metadata.xml b/games-board/mt_gtk_client/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/mt_gtk_client/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild b/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild
new file mode 100644
index 000000000000..191093914777
--- /dev/null
+++ b/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="client for the french tarot game maitretarot"
+HOMEPAGE="http://www.nongnu.org/maitretarot/"
+SRC_URI="http://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gnome"
+
+DEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-games/libmaitretarot
+ dev-games/libmt_client
+ gnome-base/libgnomeui
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
+ dev-games/cardpics"
+
+src_configure() {
+ egamesconf $(use_enable gnome gnome2)
+}
+
+src_install() {
+ default
+ if [[ -d "${D}"/${GAMES_DATADIR}/locale ]] ; then
+ mv "${D}"/${GAMES_DATADIR}/locale "${D}"/usr/share/ || die
+ fi
+ prepgamesdirs
+}