summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:22:09 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:00 -0400
commit6613fa1443c5f6e5a4d18afefdf99ea604f06d76 (patch)
tree6e907fd96d51f93a610706df14d45edf5e5756be /games-board
parentgames-arcade/xscavenger: pass -std=gnu89 (diff)
downloadgentoo-6613fa1443c5f6e5a4d18afefdf99ea604f06d76.tar.gz
gentoo-6613fa1443c5f6e5a4d18afefdf99ea604f06d76.tar.bz2
gentoo-6613fa1443c5f6e5a4d18afefdf99ea604f06d76.zip
games-board/xgammon: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xgammon/xgammon-0.98-r3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/games-board/xgammon/xgammon-0.98-r3.ebuild b/games-board/xgammon/xgammon-0.98-r3.ebuild
index 7d116d14a8e6..b5c4afd2beec 100644
--- a/games-board/xgammon/xgammon-0.98-r3.ebuild
+++ b/games-board/xgammon/xgammon-0.98-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="very nice backgammon game for X"
HOMEPAGE="http://fawn.unibw-hamburg.de/steuer/xgammon/xgammon.html"
@@ -34,6 +34,8 @@ PATCHES=(
)
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}