summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-12-12 17:55:46 -0800
committerSam James <sam@gentoo.org>2024-12-13 09:34:20 +0000
commit7f3d640ffb74907dde4b2fefb5d62de074d95493 (patch)
treebeba7ebd4dd0387c92edde2ed59219bc295a8bad /games-emulation
parentmedia-libs/jg: metadata: add changelog (diff)
downloadgentoo-7f3d640ffb74907dde4b2fefb5d62de074d95493.tar.gz
gentoo-7f3d640ffb74907dde4b2fefb5d62de074d95493.tar.bz2
gentoo-7f3d640ffb74907dde4b2fefb5d62de074d95493.zip
games-emulation/mgba-jg: add 0.10.4
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mgba-jg/Manifest1
-rw-r--r--games-emulation/mgba-jg/mgba-jg-0.10.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/games-emulation/mgba-jg/Manifest b/games-emulation/mgba-jg/Manifest
index 818d715802cb..230e196a3c71 100644
--- a/games-emulation/mgba-jg/Manifest
+++ b/games-emulation/mgba-jg/Manifest
@@ -1,2 +1,3 @@
DIST mgba-0.10.2.tar.bz2 12925327 BLAKE2B 73a4a969ea99cde7d928d04ef43208b378784c73f39f6e8bc62f02da3df31ff45c82360cd3184b94e835a355bb3ccb05c2f7b70290aa886a1df7619e319cfb56 SHA512 6bf50bf4ec172fae8a8f5495bbed646f32f978ffcf271531aecea1b56b69788da1ea84bbbab4d22ae5bec0a4e64035209d5719bb5d574981770b7cd3a531798b
DIST mgba-0.10.3.tar.bz2 12943639 BLAKE2B 3adf52ce7b1a8811f3a2d0f874450a7d9ac1c88a39de2cd94846671145e2e1112b92e48a7987a711829a6a4957827f73cf26e988e8a482f43ed055ed27627d15 SHA512 6d9ebd9ce83c6f5c554e677abcf3e52b077fb79df2fb5754d5ee2441d3104208b3d15eb6f3dd3d5e11f8782d257d16b852f0dbf5907e28d638fd7fa92138f8e2
+DIST mgba-0.10.4.tar.bz2 12950129 BLAKE2B e489232c92e6221bd845eb00880f70ce3bfc755213659d44b2ff3ed7e5cc6b74637ecd3e8329351bdde79fb802e0d6179e637656b281a5454b386db7c92a9043 SHA512 dc2a6dfa5309932aef9fbd3457aabaf2625371e3db672f7d4bba2dfe2797aca72daee255144a829fc374996d1bee71f7222aab40aba1fb7f8c4211be20a90ec2
diff --git a/games-emulation/mgba-jg/mgba-jg-0.10.4.ebuild b/games-emulation/mgba-jg/mgba-jg-0.10.4.ebuild
new file mode 100644
index 000000000000..f27d3666bf7b
--- /dev/null
+++ b/games-emulation/mgba-jg/mgba-jg-0.10.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of mGBA"
+HOMEPAGE="https://gitlab.com/jgemu/mgba"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="BSD-2 MPL-2.0"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}