summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-22 22:04:33 +0000
committerSam James <sam@gentoo.org>2022-04-10 23:58:33 +0100
commit8fa751d866e2588957ba1502ba0984247f78440c (patch)
tree873de26f90103981f46af6644a8853410cc93da9 /games-engines
parentmedia-gfx/darktable: depend on dev-libs/icu (diff)
downloadgentoo-8fa751d866e2588957ba1502ba0984247f78440c.tar.gz
gentoo-8fa751d866e2588957ba1502ba0984247f78440c.tar.bz2
gentoo-8fa751d866e2588957ba1502ba0984247f78440c.zip
games-engines/devilutionx: fix automagic ccache usage
We let users enable this by themselves via e.g. FEATURES=ccache. Maintainer timeout. Closes: https://bugs.gentoo.org/813768 Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/24714 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/devilutionx/devilutionx-1.2.1-r1.ebuild3
-rw-r--r--games-engines/devilutionx/devilutionx-9999.ebuild3
-rw-r--r--games-engines/devilutionx/files/devilutionx-1.2.1-disable-ccache.patch17
3 files changed, 21 insertions, 2 deletions
diff --git a/games-engines/devilutionx/devilutionx-1.2.1-r1.ebuild b/games-engines/devilutionx/devilutionx-1.2.1-r1.ebuild
index 9dd19f639bcb..2a2abba3eba0 100644
--- a/games-engines/devilutionx/devilutionx-1.2.1-r1.ebuild
+++ b/games-engines/devilutionx/devilutionx-1.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.2.0_pre-no_bundled_font.patch" #704508
+ "${FILESDIR}/${PN}-1.2.1-disable-ccache.patch" #813768
)
DOCS=( docs/CHANGELOG.md )
diff --git a/games-engines/devilutionx/devilutionx-9999.ebuild b/games-engines/devilutionx/devilutionx-9999.ebuild
index 9dd19f639bcb..2a2abba3eba0 100644
--- a/games-engines/devilutionx/devilutionx-9999.ebuild
+++ b/games-engines/devilutionx/devilutionx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.2.0_pre-no_bundled_font.patch" #704508
+ "${FILESDIR}/${PN}-1.2.1-disable-ccache.patch" #813768
)
DOCS=( docs/CHANGELOG.md )
diff --git a/games-engines/devilutionx/files/devilutionx-1.2.1-disable-ccache.patch b/games-engines/devilutionx/files/devilutionx-1.2.1-disable-ccache.patch
new file mode 100644
index 000000000000..a89b53e63d34
--- /dev/null
+++ b/games-engines/devilutionx/files/devilutionx-1.2.1-disable-ccache.patch
@@ -0,0 +1,17 @@
+We let users enable ccache by themselves. Avoids sandbox violation.
+
+https://bugs.gentoo.org/813768
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -54,11 +54,6 @@ if(NOT VERSION_NUM)
+ endif()
+ endif()
+
+-find_program(CCACHE_PROGRAM ccache)
+-if(CCACHE_PROGRAM)
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}")
+-endif()
+-
+ if(VERSION_NUM MATCHES untagged)
+ project(DevilutionX
+ LANGUAGES C CXX)