summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-08 08:26:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-10 20:39:12 -0400
commite27625bafd1ff9d1e04b6e8b308638723531ee4c (patch)
treefc6cf61e0c3fd1e8d838b39446ff1b69dd8c2e6e /games-engines
parentdev-cpp/doctest: Stabilize 2.4.6 amd64, #817434 (diff)
downloadgentoo-e27625bafd1ff9d1e04b6e8b308638723531ee4c.tar.gz
gentoo-e27625bafd1ff9d1e04b6e8b308638723531ee4c.tar.bz2
gentoo-e27625bafd1ff9d1e04b6e8b308638723531ee4c.zip
games-engines/box2d: unbundle doctest to fix tests with glibc-2.34
Skipping leaving a bugref in the ebuild not to imply this should be removed after it's fixed with glibc-2.34 (upstream has bumped doctest in upcoming version, but may as well use system's anyway). While not the cleanest, use a symlink to avoid patching files. Closes: https://bugs.gentoo.org/806342 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/box2d/box2d-2.4.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/games-engines/box2d/box2d-2.4.1.ebuild b/games-engines/box2d/box2d-2.4.1.ebuild
index 0fe84b500b23..aa15726dd78e 100644
--- a/games-engines/box2d/box2d-2.4.1.ebuild
+++ b/games-engines/box2d/box2d-2.4.1.ebuild
@@ -15,8 +15,17 @@ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-cpp/doctest )"
BDEPEND="doc? ( app-doc/doxygen )"
+src_prepare() {
+ cmake_src_prepare
+
+ # unbundle doctest
+ rm unit-test/doctest.h || die
+ ln -s "${ESYSROOT}"/usr/include/doctest/doctest.h unit-test/ || die
+}
+
src_configure() {
local mycmakeargs=(
-DBOX2D_BUILD_TESTBED=OFF # bundled libs, broken anyway right now