summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/quake3-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/quake3-demo')
-rw-r--r--games-fps/quake3-demo/Manifest1
-rw-r--r--games-fps/quake3-demo/metadata.xml8
-rw-r--r--games-fps/quake3-demo/quake3-demo-1.11-r1.ebuild64
3 files changed, 73 insertions, 0 deletions
diff --git a/games-fps/quake3-demo/Manifest b/games-fps/quake3-demo/Manifest
new file mode 100644
index 000000000000..8e763aebbf67
--- /dev/null
+++ b/games-fps/quake3-demo/Manifest
@@ -0,0 +1 @@
+DIST linuxq3ademo-1.11-6.x86.gz.sh 49289300 SHA256 64dee3f69b6e792d1da4fe0ac98fedc7eb1e37ea1027fb609a9fadd06150a4ec SHA512 aa74f8e1e8b5036fd68761e5f38cbc3d771e9bd0d5c3cc1f5d89d7eba8fd4fda8108dfd4f31d2b846114e4ec89f6aa15849b95232e0570181a104563ec0faeb5 WHIRLPOOL 558a84cf97c142befa4585eeeeca609f3b5c1880f6fda32a79de415d28779cbe2f69e9c901f4a7d8e0f60acd6279a7a9be69834cb6acded7d31ad630ffd3847f
diff --git a/games-fps/quake3-demo/metadata.xml b/games-fps/quake3-demo/metadata.xml
new file mode 100644
index 000000000000..69805c6e0030
--- /dev/null
+++ b/games-fps/quake3-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<use>
+ <flag name='dedicated'>install only as a dedicated game serer</flag>
+</use>
+</pkgmetadata>
diff --git a/games-fps/quake3-demo/quake3-demo-1.11-r1.ebuild b/games-fps/quake3-demo/quake3-demo-1.11-r1.ebuild
new file mode 100644
index 000000000000..20cadb88a645
--- /dev/null
+++ b/games-fps/quake3-demo/quake3-demo-1.11-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="the playable demo of Quake III Arena by Id Software"
+HOMEPAGE="http://www.idsoftware.com/games/quake/quake3-arena/"
+SRC_URI="mirror://idsoftware/quake3/linux/linuxq3ademo-${PV}-6.x86.gz.sh
+ mirror://3dgamers/quake3arena/linuxq3ademo-${PV}-6.x86.gz.sh"
+
+LICENSE="Q3AEULA"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="dedicated"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ dedicated? ( app-misc/screen )
+ !dedicated? (
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/q3ded.x86
+ ${dir:1}/q3demo.x86"
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r Help demoq3
+ doins README icon.*
+
+ exeinto "${dir}"
+ newexe bin/x86/glibc-2.0/q3ded q3ded.x86
+ games_make_wrapper q3ded ./q3ded.x86 "${dir}" "${dir}"
+ if ! use dedicated; then
+ newexe bin/x86/glibc-2.0/q3demo q3demo.x86
+ games_make_wrapper q3demo ./q3demo.x86 "${dir}" "${dir}"
+ make_desktop_entry q3demo "Quake III (Demo)"
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use dedicated; then
+ elog "To play the game run:"
+ elog " q3demo"
+ fi
+ echo
+ elog "To start the gameserver, run:"
+ elog " q3ded"
+}