summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/childsplay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/childsplay')
-rw-r--r--games-kids/childsplay/Manifest3
-rw-r--r--games-kids/childsplay/childsplay-0.90.2-r1.ebuild148
-rw-r--r--games-kids/childsplay/files/childsplay4
-rw-r--r--games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch21
-rw-r--r--games-kids/childsplay/metadata.xml12
5 files changed, 188 insertions, 0 deletions
diff --git a/games-kids/childsplay/Manifest b/games-kids/childsplay/Manifest
new file mode 100644
index 000000000000..891fe59d06ff
--- /dev/null
+++ b/games-kids/childsplay/Manifest
@@ -0,0 +1,3 @@
+DIST childsplay-0.90.2.tgz 2330022 SHA256 baa7c2c6168d581d546bcea3612a513268cf2e8273f2cf748df9e1559c62e054 SHA512 0cc59f893f43f47fec18a6ba04e3d5b4c4b41e6c387fcd64859a65a0660b4d1c8803cd092932fc9d24a4d4b9784d6cc62cc2efc4e841ca62a205f17aec8dec68 WHIRLPOOL 068629fe90bb1af7ca02bebd25959488c4d52a058ffc9b4fb934abfff787aa22225909437913724479ad91e80f6b60de01b3f0c3aabb5f8a97ad426ee20b846a
+DIST childsplay_plugins-0.90.tgz 4528735 SHA256 3eff00eb1fb20f59b503071e61ca21eaf869969bb7cdc5f644ece5f6e48664c3 SHA512 f1c47c544da364bde6023cf8450d96423d214749f800d783661b6fb16f73c8bbc899ee7f997f36e11b43aff7655332c29445f865ff22dd475ad4ce4a0557e763 WHIRLPOOL ef4ed2b666c371f306e19c5e9377c1b31bc95229ee3f1a12539dbdccc6bec333a57b63f1deb1962182c2020f7a5656a196bb5212efd4dcca5d504f8571e5c815
+DIST childsplay_plugins_lfc-0.90.tgz 6159653 SHA256 629a84beb94191c786508de4476c8b7ac98b5007aa7e0d9f7d0fa4d3e43b11b2 SHA512 4fa8f59aae64520de03fd6527dbe7339f320ef377deca19fe91cf5591b364d853cfb9d73b8469417178fcf4bc074d6ed39a1704a20cb5a82657722862c749313 WHIRLPOOL d49d2c68ef94edcacb4a7aa2ca38d239558513bca2cad2a77193c6c67cd3fbdf8869cdc9a332cfae5d2753eeb5f5d0a0671f4e8687d36a969aa99d1009078c54
diff --git a/games-kids/childsplay/childsplay-0.90.2-r1.ebuild b/games-kids/childsplay/childsplay-0.90.2-r1.ebuild
new file mode 100644
index 000000000000..b1dcafc61e79
--- /dev/null
+++ b/games-kids/childsplay/childsplay-0.90.2-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="A suite of educational games for young children"
+HOMEPAGE="http://childsplay.sourceforge.net/"
+PLUGINS_VERSION="0.90"
+PLUGINS_LFC_VERSION="0.90"
+SRC_URI="mirror://sourceforge/childsplay/${P}.tgz
+ mirror://sourceforge/childsplay/${PN}_plugins-${PLUGINS_VERSION}.tgz
+ mirror://sourceforge/childsplay/${PN}_plugins_lfc-${PLUGINS_LFC_VERSION}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-image[gif,jpeg,png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+ media-libs/libogg"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ local DIR
+
+ # Copy the plugins into the main package.
+ mv ../${PN}_plugins-${PLUGINS_VERSION}/Data/AlphabetSounds Data || die
+ mv ../${PN}_plugins-${PLUGINS_VERSION}/add-score.py . || die
+ for DIR in ${PN}_plugins-${PLUGINS_VERSION} ${PN}_plugins_lfc-${PLUGINS_LFC_VERSION}; do
+ mv ../${DIR}/Data/*.icon.png Data/icons || die
+ cp -r ../${DIR}/lib/* lib || die
+ mv ../${DIR}/assetml/${PN}/* assetml/${PN} || die
+ rm -rf ../${DIR}
+ done
+ gunzip man/childsplay.6.gz
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ python_fix_shebang .
+}
+
+src_install() {
+ local fn
+
+ # The following variables are based on Childsplay's INSTALL.sh
+ _LOCALEDIR=/usr/share/locale
+ _ASSETMLDIR=/usr/share/assetml
+ _SCOREDIR=${GAMES_STATEDIR}
+ _SCOREFILE=${_SCOREDIR}/childsplay.score
+ _CPDIR=$(games_get_libdir)/childsplay
+ _SHAREDIR=${GAMES_DATADIR}/childsplay
+ _LIBDIR=${_CPDIR}/lib
+ _MODULESDIR=${_LIBDIR}
+ _SHARELIBDATADIR=${_SHAREDIR}/lib
+ _SHAREDATADIR=${_SHAREDIR}/Data
+ _RCDIR=${_SHARELIBDATADIR}/ConfigData
+ _HOME_DIR_NAME=.childsplay
+ _CHILDSPLAYRC=childsplayrc
+
+ dodir \
+ "${_CPDIR}" \
+ "${_LIBDIR}" \
+ "${_SHAREDIR}" \
+ "${_SHARELIBDATADIR}" \
+ "${_SCOREDIR}" \
+ "${_LOCALEDIR}" \
+ "${_ASSETMLDIR}"
+
+ # create BASEPATH.py
+ cat >BASEPATH.py <<EOF
+## Automated file--please do not edit
+LOCALEDIR="${_LOCALEDIR}"
+ASSETMLDIR="${_ASSETMLDIR}"
+SCOREDIR="${_SCOREDIR}"
+SCOREFILE="${_SCOREFILE}"
+CPDIR="${_CPDIR}"
+SHAREDIR="${_SHAREDIR}"
+LIBDIR="${_LIBDIR}"
+MODULESDIR="${_MODULESDIR}"
+SHARELIBDATADIR="${_SHARELIBDATADIR}"
+SHAREDATADIR="${_SHAREDATADIR}"
+RCDIR="${_RCDIR}"
+HOME_DIR_NAME="${_HOME_DIR_NAME}"
+CHILDSPLAYRC="${_CHILDSPLAYRC}"
+EOF
+
+ # copy software and data
+ cp -r *.py "${D}/${_CPDIR}" || die "cp failed"
+ cp -r Data "${D}/${_SHAREDIR}" || die "cp failed"
+ rm "${D}/${_SHAREDIR}/Data/childsplay.score" # this copy won't be used
+
+ for fn in $(ls lib); do
+ if [[ -d lib/${fn} ]] ; then
+ cp -r lib/${fn} "${D}/${_SHARELIBDATADIR}" || die
+ else
+ cp lib/${fn} "${D}/${_LIBDIR}" || die
+ fi
+ done
+
+ if [[ ${LINGUAS+set} ]]; then
+ for lang in $LINGUAS; do
+ [[ -d locale/$lang ]] && cp -r locale/$lang "${D}/${_LOCALEDIR}"
+ done
+ else
+ cp -r locale/* "${D}/${_LOCALEDIR}" || die
+ fi
+ cp -r assetml/* "${D}/${_ASSETMLDIR}" || die
+
+ # initialize the score file
+ cp Data/childsplay.score "${D}/${_SCOREFILE}" || die
+ SCORE_GAMES="Packid,Numbers,Soundmemory,Fallingletters,Findsound,Findsound2,Billiard"
+ ${PYTHON} add-score.py "${D}/${_SCOREDIR}" $SCORE_GAMES
+
+ # translate for the letters game
+ ${PYTHON} letters-trans.py "${D}/${_ASSETMLDIR}" << EOF
+Q
+EOF
+
+ doman man/childsplay.6
+ dodoc doc/README* doc/Changelog doc/copyright
+
+ # Make a launcher.
+ dogamesbin "${FILESDIR}"/childsplay
+ sed -i \
+ -e "s:GENTOO_DIR:${_CPDIR}:" \
+ -e "s:python:${PYTHON}:" \
+ "${D}${GAMES_BINDIR}"/childsplay \
+ || die "sed failed"
+
+ python_optimize "${D}${_CPDIR}"
+
+ newicon assetml/childsplay/childsplay-images/chpl-icon-48.png ${PN}.png
+ make_desktop_entry childsplay Childsplay
+
+ prepgamesdirs
+ fperms g+w "${_SCOREFILE}"
+}
diff --git a/games-kids/childsplay/files/childsplay b/games-kids/childsplay/files/childsplay
new file mode 100644
index 000000000000..eccf016836d0
--- /dev/null
+++ b/games-kids/childsplay/files/childsplay
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -z "${LANGUAGE}" ] && LANGUAGE=en
+export LANGUAGE
+python GENTOO_DIR/childsplay.py "$@"
diff --git a/games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch b/games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch
new file mode 100644
index 000000000000..742e3e02ee3c
--- /dev/null
+++ b/games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch
@@ -0,0 +1,21 @@
+--- letters-trans.py.old 2010-04-26 12:13:12.000000000 +0200
++++ letters-trans.py 2010-04-26 12:13:49.000000000 +0200
+@@ -39,7 +39,7 @@
+ import os,fnmatch,operator,sys,locale
+ from CPConstants import ASSETMLROOT
+
+-if os.environ['USER'] != 'root':
++if os.environ['LOGNAME'] != 'root':
+ print "\nOnly root can use this script, sorry.\n"
+ sys.exit(1)
+
+@@ -69,7 +69,8 @@
+ sys.exit(0)
+
+ # get description names from memory assetml, these are the words used by letters.py
+-parser = pyassetml.AssetmlParser('childsplay/memory-136x136/memory-136x136.assetml')
++assetmlfile = os.path.join(cwd,'memory-136x136.assetml')
++parser = pyassetml.AssetmlParser(assetmlfile)
+ loc = parser.get_locale()# get current locale setting, only the first two chars !!
+ wlist_org = parser.find_names((('file','.'),('description',"en")))
+ wlist = parser.find_names((('file','.'),('description',loc)))
diff --git a/games-kids/childsplay/metadata.xml b/games-kids/childsplay/metadata.xml
new file mode 100644
index 000000000000..0aefcf9cc3b4
--- /dev/null
+++ b/games-kids/childsplay/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Childsplay is a suite of educational games for young children, like gcompris,
+but without the overkill of c/c++ and the gnome environ.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">childsplay</remote-id>
+ </upstream>
+</pkgmetadata>