summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/biniax2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/biniax2')
-rw-r--r--games-puzzle/biniax2/Manifest1
-rw-r--r--games-puzzle/biniax2/biniax2-1.30.ebuild41
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-build.patch18
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch60
-rw-r--r--games-puzzle/biniax2/files/biniax2.xpm41
-rw-r--r--games-puzzle/biniax2/metadata.xml5
6 files changed, 166 insertions, 0 deletions
diff --git a/games-puzzle/biniax2/Manifest b/games-puzzle/biniax2/Manifest
new file mode 100644
index 000000000000..d3f25012ae08
--- /dev/null
+++ b/games-puzzle/biniax2/Manifest
@@ -0,0 +1 @@
+DIST biniax2-1.30-fullsrc.tar.gz 3072220 SHA256 2c09f6f0a5fe453a409d990d72a964636ee91ca91daac99f0db861b8f42531bf SHA512 180564b24051b629c29bc6245664a36b7ff9881ac5003b03b91eeebff86c89b9507c028c1155387c42debaa51482d8f1e2b08e9e9236b77da1c3f286b78be8b5 WHIRLPOOL 7016364f493791f11a28b30a870bf3b60e6271018564e057ef41b8706e3a60ffb1396f48b337c7ccb0fa3777cf3702ad4a400fffca466c7dc590ca9ab5f180bf
diff --git a/games-puzzle/biniax2/biniax2-1.30.ebuild b/games-puzzle/biniax2/biniax2-1.30.ebuild
new file mode 100644
index 000000000000..c5bf7dcf47fb
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://mordred.dir.bg/biniax/${P}-fullsrc.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}
+
+src_prepare() {
+ rm -f data/Thumbs.db
+ sed -i \
+ -e "s:data/:${GAMES_DATADIR}/${PN}/:" \
+ desktop/{gfx,snd}.c \
+ || die
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-dotfiles.patch
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+ prepgamesdirs
+}
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-build.patch b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
new file mode 100644
index 000000000000..26c053c2e98e
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
@@ -0,0 +1,18 @@
+--- makefile
++++ makefile
+@@ -4,7 +4,7 @@
+ # To execute the game you need the runtimes of SDL, SDL_mixer and SDL_image.
+
+ FLAGS=-W -WALL
+-CC=gcc
++CC?=gcc
+ FILES=biniax.c hof.c desktop/cfg.c desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c
+ INCLUDES=-I . -I desktop
+ LINKTO=-lSDL -lSDL_mixer -lSDL_image
+@@ -12,4 +12,4 @@
+ TARGET=biniax2
+
+ biniax:
+- $(CC) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
+\ No newline at end of file
++ $(CC) $(CFLAGS) $(LDFLAGS) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
new file mode 100644
index 000000000000..2cd212d6857c
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
@@ -0,0 +1,60 @@
+--- biniax.c
++++ biniax.c
+@@ -47,6 +47,8 @@
+ INCLUDES
+ ******************************************************************************/
+
++#include <unistd.h>
++
+ #include "game.h"
+ #include "lev.h"
+ #include "inc.h"
+@@ -97,6 +99,8 @@
+ UNREF( argc );
+ UNREF( argv );
+
++ chdir( getenv( "HOME" ) );
++
+ cfgInit();
+ hofInit();
+ if ( gfxInit() == BNX_FALSE )
+--- desktop/cfg.c
++++ desktop/cfg.c
+@@ -36,7 +36,7 @@
+ ******************************************************************************/
+
+ #define _Cfg_Buffer 255
+-#define csConfigName "config.bnx2"
++#define csConfigName ".config.bnx2"
+
+ struct BNX_SETUP
+ {
+--- game.h
++++ game.h
+@@ -37,7 +37,7 @@
+ DEFINITIONS
+ ******************************************************************************/
+
+-#define csSaveGameName "autosave.bnx2"
++#define csSaveGameName ".autosave.bnx2"
+
+ /******************************************************************************
+ CONSTANTS
+--- hof.c
++++ hof.c
+@@ -34,7 +34,7 @@
+ #define chCursor '_' /* Cursor ON */
+ #define chSpace ' ' /* Cursor OFF*/
+
+-#define csHOFName "hof.bnx2" /* File name */
++#define csHOFName ".hof.bnx2" /* File name */
+ #define cHOFFileSize 504 /* File size */
+
+ BNX_HALL Hof;
+@@ -292,4 +292,4 @@
+ BNX_HALL *hofGet()
+ {
+ return (BNX_HALL *) &Hof;
+-}
+\ No newline at end of file
++}
diff --git a/games-puzzle/biniax2/files/biniax2.xpm b/games-puzzle/biniax2/files/biniax2.xpm
new file mode 100644
index 000000000000..da3c5ddd7d1d
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2.xpm
@@ -0,0 +1,41 @@
+/* XPM */
+static char * icon_xpm[] = {
+"32 32 6 1",
+" c None",
+". c #800000",
+"+ c #FF8204",
+"@ c #FC4E04",
+"# c #FCA204",
+"$ c #FEC489",
+" ",
+" ",
+" ",
+" . ",
+" ++++++++++ .@. ",
+" +########$ .@@@$ ",
+" +#$$$$$$$$ $@$ ",
+" +#$ $ ",
+" +#$ ",
+" +#$ ",
+" +#$ ++++ +++ +++ ",
+" +#$ +#### +#$ +#$ ",
+" +#$ +####+ +#$ +#$ ",
+" +#$ +#$#### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ ######$ +#$ ",
+" +#$ +#$ $####$ +#$ ",
+" +#$ +#$ ####$ +#$ ",
+" $$$ $$$ $$$$ +#$ ",
+" +#$ ",
+" +#$ ",
+" . +#$ ",
+" .@. ++++++++#$ ",
+" .@@@$ +########$ ",
+" $@$ $$$$$$$$$$ ",
+" $ ",
+" ",
+" "};
diff --git a/games-puzzle/biniax2/metadata.xml b/games-puzzle/biniax2/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/biniax2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>