summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-27 07:25:05 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-27 07:45:25 +0000
commit46ff1883a6d59af4c24a6bb091910fa903e72d7d (patch)
treefa51b7dde4a2f7300a6796309657f32e7f1ea322 /games-util
parentdev-lang/ruby: add 3.1.5 (diff)
downloadgentoo-46ff1883a6d59af4c24a6bb091910fa903e72d7d.tar.gz
gentoo-46ff1883a6d59af4c24a6bb091910fa903e72d7d.tar.bz2
gentoo-46ff1883a6d59af4c24a6bb091910fa903e72d7d.zip
games-util/nml: add 0.7.5
Closes: https://bugs.gentoo.org/929598 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/Manifest1
-rw-r--r--games-util/nml/nml-0.7.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-util/nml/Manifest b/games-util/nml/Manifest
index b04958c21fa5..18d2d57c1b4b 100644
--- a/games-util/nml/Manifest
+++ b/games-util/nml/Manifest
@@ -1,2 +1,3 @@
DIST nml-0.7.1.tar.gz 562101 BLAKE2B 3c29bde63048ea276d868df8aa3e13c4f1d3949c1e2c4a973e6f5f5bff7a6e57ce5c56d6605f44d91602209967cbe732f7f9031b471de3104d6c04a41582541f SHA512 a123680f89243f29ad88f2c0bc50fe7c801bd70d7cd49d71d3e5d199b1f4042e4143b71340aea3c47d938f838647016cebc0b56e39ede627497139755c9b829e
DIST nml-0.7.4.tar.gz 569348 BLAKE2B 620f6100627d7c1cd67bbf481c96abb8be4574e0ec70cf529502980c9d8aca3660f1469fbdce99d5736d21287053b6c199a5a390f56f3704d7ceb16e6ba6582e SHA512 78a0961db3a56684fbc999f69bc5e02b9f002ba7b7a2afd39c7d4c9695b3306339ee55c4b9d711d85ca7c4c0e4d53abc71c9e0720904d44a0c388a793a28fc4b
+DIST nml-0.7.5.tar.gz 578976 BLAKE2B 630afc4b532a76ff7dea84b231636cbf8fa50197e43c11eaa1fdaa80b2acadb61d35dc07119f57417d7cdae88d39d516f52bac49aa56fa3177e287ab11bd07b2 SHA512 6c92ce5124e2c4bc641ff8c14a2e88e2576ef06dccce8fb5ffee1b1dbcee2b9640fa51410bfb7aa6b800b00274020b38161617aa41712d4d358612493ea8fe26
diff --git a/games-util/nml/nml-0.7.5.ebuild b/games-util/nml/nml-0.7.5.ebuild
new file mode 100644
index 000000000000..44f64b61cec4
--- /dev/null
+++ b/games-util/nml/nml-0.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into GRF/NFO files"
+HOMEPAGE="https://github.com/OpenTTD/nml/"
+SRC_URI="https://github.com/OpenTTD/nml/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP},zlib]
+ dev-python/ply[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+}
+
+python_test() {
+ # the tests involving sprites seem to fail when running in the ebuild,
+ # unless --no-cache is passed.
+ emake regression NML_FLAGS='-s -c --verbosity=1 --no-cache'
+}
+
+src_install() {
+ local DOCS=( README.md docs/changelog.txt )
+ distutils-r1_src_install
+
+ doman docs/nmlc.1
+}