summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-05 12:17:03 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-05 16:49:14 -0400
commit2bdc19a00dc6cc81b5df8c4d62f3741eab460783 (patch)
treec2502728e3703c0def9dc8795494c92dfc521f6d /gnome-extra
parentgnome-extra/evolution-data-server: Version bump to 3.44.4 (diff)
downloadgentoo-2bdc19a00dc6cc81b5df8c4d62f3741eab460783.tar.gz
gentoo-2bdc19a00dc6cc81b5df8c4d62f3741eab460783.tar.bz2
gentoo-2bdc19a00dc6cc81b5df8c4d62f3741eab460783.zip
gnome-extra/evolution-ews: Version bump to 3.44.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.44.4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index bff8fb920137..e38bad4f3d9d 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.44.2.tar.xz 690680 BLAKE2B 029083bcb29d8c6883105fb3e5648501f620946fb11aa60e87feb79857c3e92247ae9987e3a40c185552dd60887f6b6aab00fec3d47f8340357aabf51dcfd4b7 SHA512 dac8ddfc04993585de0dad8eb34ec7296ab2146806a49db1ef182844abee7f383187f621f5b8beaddf6ffbab431ea7d811ce02ff64b87448fb2ff324d28a3620
DIST evolution-ews-3.44.3.tar.xz 691460 BLAKE2B 7d00e2dd121d4e6263ded369e3ad6efafc52979d65db4804ea5fa5039b72431bd5d1c2f029e1bbec5a32c0427719178d29b7d95c25a9e5b43bacb0ae24a331ce SHA512 b0961b209107c2df396ff5e2dcb8e9229184a6efd6fe9412cf066470d2c73844209cf2d5e4a7e4dcebb0da5bc2119fbe5d1008b5ec58592cf307178dc680d515
+DIST evolution-ews-3.44.4.tar.xz 691396 BLAKE2B 69344bec9dffe21e54e77325929b791cc89072e9a2a2f9a0fbcf5551c1f8b13c90c4a3c2bd934956c4e1b73b306fbdd6827c6fb4ef7aee182a3bdbeb450d124a SHA512 0326b274fbcc3630ccaf6517495ce22409706f0ad16c11b189f91c27ab8921a639bb07296d51063e71cb706e66bd861044adbf146b16f9fca4b4cd9cde6edb65
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.44.4.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.44.4.ebuild
new file mode 100644
index 000000000000..b5351070c29c
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.44.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}