summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2025-01-26 18:25:45 +0100
committerPacho Ramos <pacho@gentoo.org>2025-01-26 18:27:31 +0100
commit3454ff4a592901bcfa1d0e70bb3a842bca1cd5cb (patch)
treefcac11a29aba422f209b101c1a4e5a399eb943e7 /gnome-extra
parentgnome-extra/gnome-shell-extension-pop-shell: drop 1.2.0_p20231110 (diff)
downloadgentoo-3454ff4a592901bcfa1d0e70bb3a842bca1cd5cb.tar.gz
gentoo-3454ff4a592901bcfa1d0e70bb3a842bca1cd5cb.tar.bz2
gentoo-3454ff4a592901bcfa1d0e70bb3a842bca1cd5cb.zip
gnome-extra/gnome-shell-extension-weather-in-the-clock: Support gnome 47
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/files/gnome-shell-extension-weather-in-the-clock-gnome-47.patch76
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r4.ebuild51
2 files changed, 127 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/files/gnome-shell-extension-weather-in-the-clock-gnome-47.patch b/gnome-extra/gnome-shell-extension-weather-in-the-clock/files/gnome-shell-extension-weather-in-the-clock-gnome-47.patch
new file mode 100644
index 000000000000..22d6ff18f347
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/files/gnome-shell-extension-weather-in-the-clock-gnome-47.patch
@@ -0,0 +1,76 @@
+From 42e6018943de5154971871f33599a66f10c17f26 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=D0=9E=D0=BB=D0=B5=D0=B3=20=D0=9C=D0=BE=D1=80=D0=BE=D0=B7?=
+ =?UTF-8?q?=D0=BE=D0=B2?= <mopo3ilo@gmail.com>
+Date: Thu, 12 Oct 2023 23:30:58 +0300
+Subject: [PATCH] Gnome 45 support
+
+---
+ .../extension.js | 37 +++++++++++--------
+ .../metadata.json | 2 +-
+ 2 files changed, 22 insertions(+), 17 deletions(-)
+
+diff --git a/weatherintheclock@JasonLG1979.github.io/extension.js b/weatherintheclock@JasonLG1979.github.io/extension.js
+index 7b097a4..dcb08b9 100644
+--- a/weatherintheclock@JasonLG1979.github.io/extension.js
++++ b/weatherintheclock@JasonLG1979.github.io/extension.js
+@@ -18,27 +18,32 @@
+ * If this extension breaks your desktop you get to keep all of the pieces...
+ */
+
+-const {Clutter, GLib, GObject, St} = imports.gi;
+-const [major, minor] = imports.misc.config.PACKAGE_VERSION.split('.').map(s => Number(s));
++import Clutter from "gi://Clutter";
++import GLib from "gi://GLib";
++import GObject from "gi://GObject";
++import St from "gi://St";
++import * as Main from "resource:///org/gnome/shell/ui/main.js";
+
+ let panelWeather = null;
+
+-function enable() {
+- if (!panelWeather) {
+- let statusArea = imports.ui.main.panel.statusArea;
+- let dateMenu = statusArea.dateMenu;
+- let weather = dateMenu._weatherItem._weatherClient;
+- let network = (major < 43) ? statusArea.aggregateMenu._network : statusArea.quickSettings._network;
+- let networkIcon = network ? network._primaryIndicator : null;
+- panelWeather = new PanelWeather(weather, networkIcon);
+- dateMenu.get_first_child().insert_child_above(panelWeather, dateMenu._clockDisplay);
++export default class weatherInTheClock {
++ enable() {
++ if (!panelWeather) {
++ let statusArea = Main.panel.statusArea;
++ let dateMenu = statusArea.dateMenu;
++ let weather = dateMenu._weatherItem._weatherClient;
++ let network = statusArea.quickSettings._network;
++ let networkIcon = network ? network._primaryIndicator : null;
++ panelWeather = new PanelWeather(weather, networkIcon);
++ dateMenu.get_first_child().insert_child_above(panelWeather, dateMenu._clockDisplay);
++ }
+ }
+-}
+
+-function disable() {
+- if (panelWeather) {
+- panelWeather.destroy();
+- panelWeather = null;
++ disable() {
++ if (panelWeather) {
++ panelWeather.destroy();
++ panelWeather = null;
++ }
+ }
+ }
+
+diff --git a/weatherintheclock@JasonLG1979.github.io/metadata.json b/weatherintheclock@JasonLG1979.github.io/metadata.json
+index 2566fc3..1151690 100644
+--- a/weatherintheclock@JasonLG1979.github.io/metadata.json
++++ b/weatherintheclock@JasonLG1979.github.io/metadata.json
+@@ -3,6 +3,6 @@
+ "name": "Weather In The Clock",
+ "description": "Display the current Weather in the Clock. GNOME Weather is required for this extension to function.",
+ "original-author": "JasonLG1979@github.io",
+-"shell-version": ["3.38", "40", "41", "42", "43"],
++"shell-version": ["45", "46", "47"],
+ "url": "https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/"
+ }
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r4.ebuild b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r4.ebuild
new file mode 100644
index 000000000000..60cb9e1d0402
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Display the current weather in the clock"
+HOMEPAGE="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
+COMMIT="38ba36090961a37260215ae04f4a7e0a1377da95"
+SRC_URI="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+ gnome-extra/gnome-weather
+"
+
+extension_uuid="weatherintheclock@JasonLG1979.github.io"
+
+PATCHES=(
+ # https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/pull/32
+ "${FILESDIR}/${PN}-gnome-47.patch"
+)
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/gnome-shell/extensions/
+ doins -r "${extension_uuid}"
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}