summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-03 18:14:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-03 19:32:56 -0400
commit165177eebb539f0899cad4978092e891c3c688a7 (patch)
tree4e1991c8ec186f653d939fa185b500c8c092775d /gui-libs/egl-wayland
parentsys-libs/libcap: add 2.56 (diff)
downloadgentoo-165177eebb539f0899cad4978092e891c3c688a7.tar.gz
gentoo-165177eebb539f0899cad4978092e891c3c688a7.tar.bz2
gentoo-165177eebb539f0899cad4978092e891c3c688a7.zip
gui-libs/egl-wayland: add 1.1.8
This version requires >=libglvnd-1.3.4 to build at all. As a bonus, restriction allows to drop the -DEGL_NO_X11 workaround. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs/egl-wayland')
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 9f8227523798..d6e204049fff 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1 +1,2 @@
DIST egl-wayland-1.1.7.tar.gz 48681 BLAKE2B eebbd0e36045c50b39ef70292156f5cd137a51af2169b56a35d318d90ade3d4a5b94206d86246d52fda0c6c093ff25e389b1a3ccbe60595dc9661d199e30f33b SHA512 edc81d9f2c617587044d5f9d35b3e355db8544e8fa1d861c1b92a5a11bc1af7d994ca8abd49ce6f462a1971f20296b4c757bdf1df0d2bfc981cdafaa839f12af
+DIST egl-wayland-1.1.8.tar.gz 53776 BLAKE2B 452f56a54abb2db11e9041b8c21bc0cd57e1583449bcbc7c4fed90c1f7504102598d72d5bf4c1582392f609579bd84cec5b42d078c6b12843f15d56484982c04 SHA512 2308789f68447e8993acca88b86d21787b235de4c457aa66d1b49005ac7b159a07c4d6666b9e1beb490572b06da6b83283cd936e7beed140844955edca6f2338
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.8.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.8.ebuild
new file mode 100644
index 000000000000..5a213c283b8b
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/wayland
+ !<x11-drivers/nvidia-drivers-470.57.02[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ gui-libs/eglexternalplatform
+ >=media-libs/libglvnd-1.3.4"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if has_version "<x11-drivers/nvidia-drivers-391"; then
+ ewarn "<=nvidia-drivers-390.xx may not work properly with this version of"
+ ewarn "egl-wayland, it is recommended to use nouveau drivers for wayland."
+ fi
+}