summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 20:48:11 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 20:49:11 -0400
commit1d9fe395da43eab2ad848248bb948e946e7e00f6 (patch)
treeaf1f5e807b38cedb83f1e162d48cfefeec1d65cd /gui-libs
parentdev-util/gnome-builder: Version bump to 3.40.0 (diff)
downloadgentoo-1d9fe395da43eab2ad848248bb948e946e7e00f6.tar.gz
gentoo-1d9fe395da43eab2ad848248bb948e946e7e00f6.tar.bz2
gentoo-1d9fe395da43eab2ad848248bb948e946e7e00f6.zip
gui-libs/libwpe: Version bump to 1.10.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libwpe/Manifest1
-rw-r--r--gui-libs/libwpe/libwpe-1.10.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/gui-libs/libwpe/Manifest b/gui-libs/libwpe/Manifest
index 6b63520f3ff6..02987cd66f1f 100644
--- a/gui-libs/libwpe/Manifest
+++ b/gui-libs/libwpe/Manifest
@@ -1 +1,2 @@
+DIST libwpe-1.10.0.tar.xz 52004 BLAKE2B 3088cb103b99ab626a74c37910d91fe8abdb07d14d0846bd202716fa1a7d8087e4095e65977e25d9a6f2b97bdfcef664f3872abd8de447ffe3e841a613ebc116 SHA512 b5634dd71cca70eb960f3c045ad109346ab6ce6b01aa8c8bc8f326d232eb16ac1600757896a4b99720af3c77084351ea4f69e2e2c81b9c32cc8bc12a5c66ba3c
DIST libwpe-1.8.0.tar.xz 51260 BLAKE2B d5f5249e3fffba03a0e87e6a8b2a261e426dc25c2a57d5e060d81f7618e957884c1c74a86a79216d4e5e85f9e173e7629be9c6a674898b20e701fd59d487bd32 SHA512 38b02d97f9ee40a1bb345ba0766acd1852500c704447bde224ac79f41e91abc06fb3047119f9843a11c78cdd5899287ab86ccedbcaefb51e366a1810f2f42fa8
diff --git a/gui-libs/libwpe/libwpe-1.10.0.ebuild b/gui-libs/libwpe/libwpe-1.10.0.ebuild
new file mode 100644
index 000000000000..0e9f6488f905
--- /dev/null
+++ b/gui-libs/libwpe/libwpe-1.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ media-libs/mesa[egl]
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS=OFF # hotdoc not packaged
+ )
+
+ cmake_src_configure
+}