summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-10 00:04:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-10 01:04:33 +0100
commit4eb458f6148a654b3670207fe0c0301bb4b24c07 (patch)
tree35af214f967f60ce853a7448dab6ac0ad4023fe2 /kde-frameworks
parentapp-office/libreoffice: backport patch for >=zxing-cpp-1.4.0 (diff)
downloadgentoo-4eb458f6148a654b3670207fe0c0301bb4b24c07.tar.gz
gentoo-4eb458f6148a654b3670207fe0c0301bb4b24c07.tar.bz2
gentoo-4eb458f6148a654b3670207fe0c0301bb4b24c07.zip
kde-frameworks/prison: backport patch for >=zxing-cpp-2.0.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/prison/files/prison-5.99.0-zxing-2.patch31
-rw-r--r--kde-frameworks/prison/prison-5.101.0.ebuild4
-rw-r--r--kde-frameworks/prison/prison-5.99.0.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/kde-frameworks/prison/files/prison-5.99.0-zxing-2.patch b/kde-frameworks/prison/files/prison-5.99.0-zxing-2.patch
new file mode 100644
index 000000000000..946cf9d1cc34
--- /dev/null
+++ b/kde-frameworks/prison/files/prison-5.99.0-zxing-2.patch
@@ -0,0 +1,31 @@
+From 14fb6f0a31373b242bdeb18cf9f3a36441bf86b5 Mon Sep 17 00:00:00 2001
+From: Volker Krause <vkrause@kde.org>
+Date: Tue, 3 Jan 2023 16:55:59 +0100
+Subject: [PATCH] Add support for ZXing 2.0
+
+As far as we are concerned that is source-compatible, so nothing we need
+to change here apart from adjusting the build system to accept the new
+major version.
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 365a1c9..961262e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -44,7 +44,10 @@ find_package(Dmtx)
+ set_package_properties(Dmtx PROPERTIES
+ PURPOSE "Required for generation of Data Matrix barcodes."
+ TYPE RECOMMENDED)
+-find_package(ZXing 1.2.0)
++find_package(ZXing 2.0)
++if (NOT TARGET ZXing::ZXing)
++ find_package(ZXing 1.2.0)
++endif()
+ set_package_properties(ZXing PROPERTIES
+ PURPOSE "Required for generation of PDF417 barcodes and for scanning of barcodes from live video feed."
+ TYPE RECOMMENDED)
+--
+GitLab
+
diff --git a/kde-frameworks/prison/prison-5.101.0.ebuild b/kde-frameworks/prison/prison-5.101.0.ebuild
index 2972465702e6..f16d66fabd46 100644
--- a/kde-frameworks/prison/prison-5.101.0.ebuild
+++ b/kde-frameworks/prison/prison-5.101.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
"
+PATCHES=( "${FILESDIR}/${PN}-5.99.0-zxing-2.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt5Quick)
diff --git a/kde-frameworks/prison/prison-5.99.0.ebuild b/kde-frameworks/prison/prison-5.99.0.ebuild
index da509e07e78b..0de668735817 100644
--- a/kde-frameworks/prison/prison-5.99.0.ebuild
+++ b/kde-frameworks/prison/prison-5.99.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
"
+PATCHES=( "${FILESDIR}/${P}-zxing-2.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt5Quick)