summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Pronin <dannftk@yandex.ru>2024-02-19 15:23:42 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-06-09 09:24:01 +0300
commit308ef54ee21bbaf93f9d3c17c2809c660f580942 (patch)
tree58524a81e54e788d0b5d7cfd02a4e8515050b01d /media-gfx
parentsys-apps/syd: drop 3.21.0 (diff)
downloadgentoo-308ef54ee21bbaf93f9d3c17c2809c660f580942.tar.gz
gentoo-308ef54ee21bbaf93f9d3c17c2809c660f580942.tar.bz2
gentoo-308ef54ee21bbaf93f9d3c17c2809c660f580942.zip
media-gfx/librecad: add a patch to fix building with clang
fix missing FILE declaration in lib/debug/rs_debug.h Closes: https://bugs.gentoo.org/919822 Signed-off-by: Denis Pronin <dannftk@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/35423 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/librecad/files/librecad-2.2.0-fix-missing-header.patch29
-rw-r--r--media-gfx/librecad/librecad-2.2.0.ebuild6
2 files changed, 34 insertions, 1 deletions
diff --git a/media-gfx/librecad/files/librecad-2.2.0-fix-missing-header.patch b/media-gfx/librecad/files/librecad-2.2.0-fix-missing-header.patch
new file mode 100644
index 000000000000..3caec03b011a
--- /dev/null
+++ b/media-gfx/librecad/files/librecad-2.2.0-fix-missing-header.patch
@@ -0,0 +1,29 @@
+The patch is borrowed from upstream https://github.com/LibreCAD/LibreCAD
+
+https://github.com/LibreCAD/LibreCAD/commit/6e0f1556bbd554e528295f92597a80a109344607
+
+https://bugs.gentoo.org/919822
+
+commit 6e0f1556bbd554e528295f92597a80a109344607
+Author: Denis Pronin <dannftk@yandex.ru>
+Date: Sun Jun 2 22:23:11 2024 +0300
+
+ fix compilation with clang and llvm's libcxx
+
+ librecad/src/lib/debug/rs_debug.h requires cstdio to be included because of FILE
+ type being used
+
+ Signed-off-by: Denis Pronin <dannftk@yandex.ru>
+
+diff --git a/librecad/src/lib/debug/rs_debug.h b/librecad/src/lib/debug/rs_debug.h
+index 23918574..8950efcc 100644
+--- a/librecad/src/lib/debug/rs_debug.h
++++ b/librecad/src/lib/debug/rs_debug.h
+@@ -28,6 +28,7 @@
+ #ifndef RS_DEBUG_H
+ #define RS_DEBUG_H
+
++#include <cstdio>
+ #include <iosfwd>
+ #ifdef __hpux
+ #include <sys/_size_t.h>
diff --git a/media-gfx/librecad/librecad-2.2.0.ebuild b/media-gfx/librecad/librecad-2.2.0.ebuild
index 092799ec110b..f86b8253e177 100644
--- a/media-gfx/librecad/librecad-2.2.0.ebuild
+++ b/media-gfx/librecad/librecad-2.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,6 +40,10 @@ BDEPEND="
dev-qt/linguist-tools:5
"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-missing-header.patch"
+)
+
src_prepare() {
default