summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/lv2core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/lv2core')
-rw-r--r--media-libs/lv2core/Manifest3
-rw-r--r--media-libs/lv2core/lv2core-3.0.ebuild33
-rw-r--r--media-libs/lv2core/lv2core-4.0.ebuild33
-rw-r--r--media-libs/lv2core/lv2core-6.0.ebuild23
-rw-r--r--media-libs/lv2core/metadata.xml5
5 files changed, 97 insertions, 0 deletions
diff --git a/media-libs/lv2core/Manifest b/media-libs/lv2core/Manifest
new file mode 100644
index 000000000000..6cb05d7cc2f1
--- /dev/null
+++ b/media-libs/lv2core/Manifest
@@ -0,0 +1,3 @@
+DIST lv2core-3.0.tar.bz2 104167 SHA256 7b209b6d5f8a9a597dae0c76f077be19db0fd2f764e9970cfbf87f3406c50172
+DIST lv2core-4.0.tar.gz 129749 SHA256 a37c6b915c4f6ef8414f83ac356a1f802ab97badf3b58cd469ad9d1f7583d08f
+DIST lv2core-6.0.tar.bz2 106475 SHA256 b05429f1cade75ad559a72d65d78a927f9718e074e3aeb9698510403a4e52309 SHA512 3782459a3684a8cb1825ade13adfbd69d496adaeffca026dd47f0405e5d09f8a125726760506890595664cba3ec18ebaaaac681e08e73acbee9cb4377ad2db9c WHIRLPOOL e8a66ba2ad051230391e972a76935e00761afd9acc99ee2556fb6e7966780e8838025bbedda76a3b2c9d09649eab71b9125f9b9efcea03f106c0a31f38761ac2
diff --git a/media-libs/lv2core/lv2core-3.0.ebuild b/media-libs/lv2core/lv2core-3.0.ebuild
new file mode 100644
index 000000000000..4844896110f1
--- /dev/null
+++ b/media-libs/lv2core/lv2core-3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
+HOMEPAGE="http://lv2plug.in/"
+SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<media-libs/slv2-0.4.2"
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure --prefix=/usr --libdir=/usr/$(get_libdir)/ || die "failed to configure"
+}
+
+src_compile() {
+ ./waf || die "failed to build"
+}
+
+src_install() {
+ ./waf --destdir="${D}" install || die "install failed"
+ dodoc AUTHORS README ChangeLog
+}
diff --git a/media-libs/lv2core/lv2core-4.0.ebuild b/media-libs/lv2core/lv2core-4.0.ebuild
new file mode 100644
index 000000000000..6fc121b29666
--- /dev/null
+++ b/media-libs/lv2core/lv2core-4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
+HOMEPAGE="http://lv2plug.in/"
+SRC_URI="http://lv2plug.in/spec/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<media-libs/slv2-0.4.2"
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure --prefix=/usr --libdir=/usr/$(get_libdir) || die "failed to configure"
+}
+
+src_compile() {
+ ./waf || die "failed to build"
+}
+
+src_install() {
+ ./waf --destdir="${D}" install || die "install failed"
+ dodoc AUTHORS README ChangeLog
+}
diff --git a/media-libs/lv2core/lv2core-6.0.ebuild b/media-libs/lv2core/lv2core-6.0.ebuild
new file mode 100644
index 000000000000..b2d6ffa8df80
--- /dev/null
+++ b/media-libs/lv2core/lv2core-6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
+HOMEPAGE="http://lv2plug.in/"
+SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="!<media-libs/slv2-0.4.2"
+DOCS=( "AUTHORS" "README" "NEWS" )
diff --git a/media-libs/lv2core/metadata.xml b/media-libs/lv2core/metadata.xml
new file mode 100644
index 000000000000..0dc3775f83d7
--- /dev/null
+++ b/media-libs/lv2core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>