summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-04-25 09:56:01 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2016-04-25 09:56:42 +0200
commit411d95bd22109e0bb667e4dab23b13c272f897e1 (patch)
tree84cd4e64f0b9976c2260ca13a5bac62ddb44ea86 /media-libs/raspberrypi-userland
parentsys-libs/freeipmi: Removed old. (diff)
downloadgentoo-411d95bd22109e0bb667e4dab23b13c272f897e1.tar.gz
gentoo-411d95bd22109e0bb667e4dab23b13c272f897e1.tar.bz2
gentoo-411d95bd22109e0bb667e4dab23b13c272f897e1.zip
media-libs/raspberrypi-userland: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-libs/raspberrypi-userland')
-rw-r--r--media-libs/raspberrypi-userland/Manifest1
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland/Manifest b/media-libs/raspberrypi-userland/Manifest
index 1823f230ec75..9aeb8badae34 100644
--- a/media-libs/raspberrypi-userland/Manifest
+++ b/media-libs/raspberrypi-userland/Manifest
@@ -5,3 +5,4 @@ DIST raspberrypi-userland-0_pre20150921.tar.xz 32395092 SHA256 771bf96111d40c3b8
DIST raspberrypi-userland-0_pre20160305.tar.gz 32888927 SHA256 01cc6dfb5ee50733d58e6cb1ba0f79cb90ab7ef46718c302cbac0fd9e3a09b6a SHA512 8621f48d699b2736d4a22f03e5cdde6be564b8d2100f46ab85d3f6e0fc958634436fafc8d218f55a114a37acaf6dbe21b5cf2bf57c258a3067af2720d63d0c27 WHIRLPOOL 109aabddfc483900741758a737f93c1f3bc4074de2e2f0d25d28a620f8381adb44d21b5fa8eb3f59a69eb3a9903b95b32e3a5d9d9353560d42e37d19aaa9b085
DIST raspberrypi-userland-0_pre20160330.tar.gz 32928211 SHA256 a1f3772afee594c7f08e5362cff96d783d2a0a4970d0172c611a638fe93cfeea SHA512 5b56885a1d832fff7d806718341d0050df66641d698ead4997e684c2aedb8faebd5cd9ce84a69537cc0ed362ca1b6c487ff2fd5575f5a3fbb1d4a7fe8602fb6e WHIRLPOOL ec3d224715e351150f72d021fd5a623287a64bc39379137cde01f8c460e083069f9cc18cf4899fff43d69a711b4c5bd9c69f51113b3b0a6b5092bb62441d9355
DIST raspberrypi-userland-0_pre20160408.tar.gz 32930276 SHA256 006500715b4131db263b81059685877eeb46b2591c13f772fa9f79b2368f195a SHA512 f42c561d1b9ebe9fe6335166a35e47d5dc932c1fefe567458f6a4ae9c57849ccf33e8ede8144989e3a1fa4c9b2a6c892cf61f77d69350d590443d0360388814b WHIRLPOOL 786ca22ad4e7a9740b853d7adbf362b618add9f12e987192f40bf012fdb313dcf9a38b27c963e87566cf91c98c4f02d59d8ef2eee602ea13369036c4e3a7891c
+DIST raspberrypi-userland-0_pre20160424.tar.gz 32933952 SHA256 e040448cec34b9cea0072977397391af3131b2b43b057beba2ecf8b098d70b77 SHA512 04a71837b1247ecbbe479b3b09b5705638a9e576dc99a1ab2200727509195a4a2f2a9b184e3c23ce3933a3236b260afc8bd2b75bc218567b386445bdd8208a5b WHIRLPOOL 95d6472d2f64e047d296cbebc122fe62eb392f861ad069e5a092a2d5710e7f85824e7a69e68d5af68d91b567c973b7e8b95135bf8b5a0bcfa58b683b35a8ed44
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
new file mode 100644
index 000000000000..ebcc3228452d
--- /dev/null
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/userland"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ GIT_COMMIT="dff5760"
+ SRC_URI="https://github.com/raspberrypi/userland/tarball/${GIT_COMMIT} -> ${P}.tar.gz"
+ KEYWORDS="~arm"
+ S="${WORKDIR}/raspberrypi-userland-${GIT_COMMIT}"
+fi
+
+RDEPEND="!media-libs/raspberrypi-userland-bin
+ wayland? ( dev-libs/wayland )"
+DEPEND="${RDEPEND}
+ wayland? ( virtual/pkgconfig )"
+
+IUSE="examples wayland"
+LICENSE="BSD"
+SLOT="0"
+
+# TODO:
+# * port vcfiled init script
+# * stuff is still installed to hardcoded /opt/vc location, investigate whether
+# anything else depends on it being there
+# * live ebuild
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ # init script for Debian, not useful on Gentoo
+ sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
+
+ # wayland egl support
+ epatch "${FILESDIR}"/next-resource-handle.patch \
+ "${FILESDIR}"/wayland-wsys.patch
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # provide OpenGL ES v1 according to https://github.com/raspberrypi/firmware/issues/78
+ dosym libGLESv2.so /opt/vc/lib/libGLESv1_CM.so
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/92-local-vchiq-permissions.rules
+
+ # enable dynamic switching of the GL implementation
+ dodir /usr/lib/opengl
+ dosym ../../../opt/vc /usr/lib/opengl/${PN}
+
+ # tell eselect opengl that we do not have libGL
+ touch "${ED}"/opt/vc/.gles-only
+
+ insinto /opt/vc/lib/pkgconfig
+ doins "${FILESDIR}"/bcm_host.pc
+ doins "${FILESDIR}"/egl.pc
+ doins "${FILESDIR}"/glesv2.pc
+ if use wayland; then
+ # Missing wayland-egl version from the patch; claim 9.0 (a mesa version) for now, so gst-plugins-bad wayland-egl check is happy
+ sed -i -e 's/Version: /Version: 9.0/' "${ED}"/opt/vc/lib/pkgconfig/wayland-egl.pc
+ doins "${ED}"/opt/vc/lib/pkgconfig/wayland-egl.pc # Maybe move?
+ fi
+
+ # some #include instructions are wrong so we need to fix them
+ einfo "Fixing #include \"vcos_platform_types.h\""
+ for file in $(grep -l "#include \"vcos_platform_types.h\"" "${D}"/opt/vc/include/* -r); do
+ einfo " Fixing file ${file}"
+ sed -i "s%#include \"vcos_platform_types.h\"%#include \"interface/vcos/pthreads/vcos_platform_types.h\"%g" ${file}
+ done
+ einfo "Fixing #include \"vcos_platform.h\""
+ for file in $(grep -l "#include \"vcos_platform.h\"" "${D}"/opt/vc/include/* -r); do
+ einfo " Fixing file ${file}"
+ sed -i "s%#include \"vcos_platform.h\"%#include \"interface/vcos/pthreads/vcos_platform.h\"%g" ${file}
+ done
+ einfo "Fixing #include \"vchost_config.h\""
+ for file in $(grep -l "#include \"vchost_config.h\"" "${D}"/opt/vc/include/* -r); do
+ einfo " Fixing file ${file}"
+ sed -i "s%#include \"vchost_config.h\"%#include \"interface/vmcs_host/linux/vchost_config.h\"%g" ${file}
+ done
+
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ mv "${D}"/opt/vc/src/hello_pi "${D}"/usr/share/doc/${PF}/examples/ || die
+ rm -fr "${D}"/opt/vc/src
+ else
+ rm -fr "${D}/opt/vc/src"
+ fi
+}