summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sampleicc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sampleicc')
-rw-r--r--media-libs/sampleicc/Manifest2
-rw-r--r--media-libs/sampleicc/metadata.xml10
-rw-r--r--media-libs/sampleicc/sampleicc-1.6.6.ebuild32
-rw-r--r--media-libs/sampleicc/sampleicc-1.6.8.ebuild21
4 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/sampleicc/Manifest b/media-libs/sampleicc/Manifest
new file mode 100644
index 000000000000..2c14f32ad4b7
--- /dev/null
+++ b/media-libs/sampleicc/Manifest
@@ -0,0 +1,2 @@
+DIST SampleICC-1.6.6.tar.gz 660936 SHA256 675f3ee0e7c7f158b663c6a4db04110e7e94de454a46a5904a6d9f318c2de0f5
+DIST SampleICC-1.6.8.tar.gz 708069 SHA256 8b23bc6b9e4b8d304dc239bf874078edf7764e999aee4e11e7ed2d1c0271b965 SHA512 54d9f1fd9a7606d0c723bc0f86b3d54c4d1a54ecc4a3aeea665cb8c58df6555e65dd3706dee05e4c89e8a4ff7abf9f726c54c572b32db710e5b2c22b124bddc8 WHIRLPOOL 6cee6d2d59b89ed222637444abcb0070b142057c671d181581f1bb566001c7a530c0253bec50023470576f6979ca670df727060f9f802465ddb0bc423ca45de9
diff --git a/media-libs/sampleicc/metadata.xml b/media-libs/sampleicc/metadata.xml
new file mode 100644
index 000000000000..8cc14b831e73
--- /dev/null
+++ b/media-libs/sampleicc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sampleicc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/sampleicc/sampleicc-1.6.6.ebuild b/media-libs/sampleicc/sampleicc-1.6.6.ebuild
new file mode 100644
index 000000000000..fddca7d0434f
--- /dev/null
+++ b/media-libs/sampleicc/sampleicc-1.6.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="C++ library for reading, writing, manipulating, and applying ICC profiles"
+HOMEPAGE="http://sampleicc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/SampleICC-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="media-libs/tiff"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SampleICC-${PV}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/media-libs/sampleicc/sampleicc-1.6.8.ebuild b/media-libs/sampleicc/sampleicc-1.6.8.ebuild
new file mode 100644
index 000000000000..4566096fc9c7
--- /dev/null
+++ b/media-libs/sampleicc/sampleicc-1.6.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="C++ library for reading, writing, manipulating, and applying ICC profiles"
+HOMEPAGE="http://sampleicc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/SampleICC-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="media-libs/tiff"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SampleICC-${PV}