summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-15 23:15:09 +0000
committerSam James <sam@gentoo.org>2025-01-15 23:15:09 +0000
commit789e82b5e0baae616ec7dc6b4aa20cf0a0cc8e45 (patch)
treed29a91e382bc101ec857f9228da612b0c695e443 /media-libs
parentnet-misc/rsync: Stabilize 3.3.0-r2 sparc, #948151 (diff)
downloadgentoo-789e82b5e0baae616ec7dc6b4aa20cf0a0cc8e45.tar.gz
gentoo-789e82b5e0baae616ec7dc6b4aa20cf0a0cc8e45.tar.bz2
gentoo-789e82b5e0baae616ec7dc6b4aa20cf0a0cc8e45.zip
media-libs/nas: fix build issues
* Build w/ -std=gnu89 (ancient configure, not C23 compatible either) * Ignore MAKEOPTS/GNUMAKEFLAGS as it confuses imake Closes: https://bugs.gentoo.org/899834 Closes: https://bugs.gentoo.org/944403 Closes: https://bugs.gentoo.org/944451 Closes: https://bugs.gentoo.org/947416 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/nas/nas-1.9.5-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-libs/nas/nas-1.9.5-r2.ebuild b/media-libs/nas/nas-1.9.5-r2.ebuild
index 8fb0b91a04be..e548bf7f0d89 100644
--- a/media-libs/nas/nas-1.9.5-r2.ebuild
+++ b/media-libs/nas/nas-1.9.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # Ancient configure and relies on imake, not worth it
+ append-cflags -std=gnu89
+
# -Werror=lto-type-mismatch
# https://bugs.gentoo.org/859934
# https://sourceforge.net/p/nas/bugs/13/
@@ -60,6 +63,9 @@ multilib_src_configure() {
econf
popd || die
+ # bug #947416
+ unset MAKEOPTS GNUMAKEFLAGS
+
local cpp=($(get_abi_CHOST ${DEFAULT_ABI})-gcc $(get_abi_CFLAGS) -E) #884203
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${cpp[*]}}" \