summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-05-08 12:55:49 +0300
committerSam James <sam@gentoo.org>2022-05-12 22:42:34 +0000
commit3915b764b76507c595f389ff6870bb1d79c3ef52 (patch)
treed9f568b7773c195ce68a88f4581e5f318c30e7dd /media-plugins/gst-plugins-dash/gst-plugins-dash-1.20.2.ebuild
parentapp-emacs/haxe-mode: new package; add version 0.3.3 (diff)
downloadgentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.tar.gz
gentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.tar.bz2
gentoo-3915b764b76507c595f389ff6870bb1d79c3ef52.zip
media-libs/gstreamer: Version bump, 1.20.2
Bug: https://bugs.gentoo.org/843770 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-dash/gst-plugins-dash-1.20.2.ebuild')
-rw-r--r--media-plugins/gst-plugins-dash/gst-plugins-dash-1.20.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-dash/gst-plugins-dash-1.20.2.ebuild b/media-plugins/gst-plugins-dash/gst-plugins-dash-1.20.2.ebuild
new file mode 100644
index 000000000000..53a243db197d
--- /dev/null
+++ b/media-plugins/gst-plugins-dash/gst-plugins-dash-1.20.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="MPEG-DASH plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_library gstisoff_dep:gstisoff
+ gstreamer_system_package pbutils_dep:gstreamer-pbutils
+ gstreamer_system_package tag_dep:gstreamer-tag
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}