summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-image
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-image')
-rw-r--r--media-plugins/vdr-image/Manifest2
-rw-r--r--media-plugins/vdr-image/files/rc-addon-0.3.0.sh22
-rw-r--r--media-plugins/vdr-image/files/vdr-image-0.3.1-ffmpeg-1.patch40
-rw-r--r--media-plugins/vdr-image/files/vdr-image-0.3.1-gentoo.diff24
-rw-r--r--media-plugins/vdr-image/files/vdr-image-0.4.0-gentoo.diff24
-rw-r--r--media-plugins/vdr-image/metadata.xml15
-rw-r--r--media-plugins/vdr-image/vdr-image-0.3.1.ebuild66
-rw-r--r--media-plugins/vdr-image/vdr-image-0.4.0.ebuild64
8 files changed, 257 insertions, 0 deletions
diff --git a/media-plugins/vdr-image/Manifest b/media-plugins/vdr-image/Manifest
new file mode 100644
index 000000000000..f3987673ae0a
--- /dev/null
+++ b/media-plugins/vdr-image/Manifest
@@ -0,0 +1,2 @@
+DIST vdr-image-0.3.1.tar.gz 124587 SHA256 953c27a6fbebb17590cc6ffe367720d92fb0f256da934bd06bd86aabfaa8e15b SHA512 a5a3b9d29958abc486d5fce4a6423d574894a604f792fe6e73b49daf3c02fe2df1ec7d7538db2a950482a77c7d47ebd8dd498ae55f265a0a7ef013b607dd0efb WHIRLPOOL 6541b2a1f1a7e8da241878d46c0976b2d688522c2143a2d66e6c2b124343a068b000bd2a2df647bd82db858ec73e3db136ea61f77fba28d5369fcbce5dd3d1bb
+DIST vdr-image-0.4.0.tgz 129200 SHA256 45b9d550698a8871e54c53ca594d0fe81bd4b03b273d106c1dfbdc728a2aa68c SHA512 d66bb7ff48ed622ec21a7d828985229b6aaf908123c12b870e531f09dfe85e792afafa096cd5c4580296139275e2f7171d30f21fe1f8d88978e19c1eb36ab169 WHIRLPOOL 9a7930bf562eac1ba12b204c7f578fc202b453cc28f1a1c84e449eed05587adc0e4c17ec46214ebe8602ddaff3ec9e6214e2ff334247d8d181302ff491ab62d2
diff --git a/media-plugins/vdr-image/files/rc-addon-0.3.0.sh b/media-plugins/vdr-image/files/rc-addon-0.3.0.sh
new file mode 100644
index 000000000000..f4030e082ab8
--- /dev/null
+++ b/media-plugins/vdr-image/files/rc-addon-0.3.0.sh
@@ -0,0 +1,22 @@
+# $Id$
+#
+# rc-addon plugin-startup-skript for vdr-image
+#
+
+: ${IMAGE_MOUNT:=/usr/share/vdr/image/bin/mount-image.sh}
+: ${IMAGE_CONVERT:=/usr/share/vdr/image/bin/imageplugin.sh}
+
+plugin_pre_vdr_start() {
+ add_plugin_param "-m ${IMAGE_MOUNT}"
+ add_plugin_param "-C ${IMAGE_CONVERT}"
+ add_plugin_param "-c image"
+
+ if [ -f /usr/lib/vdr/inc/commands-functions.sh ]; then
+ . /usr/lib/vdr/inc/commands-functions.sh
+ else
+ #source /usr/share/vdr/inc/functions.sh
+ include commands-functions
+ fi
+
+ merge_commands_conf /etc/vdr/imagecmds /etc/vdr/plugins/image/imagecmds.conf "${ORDER_IMAGECMDS}"
+}
diff --git a/media-plugins/vdr-image/files/vdr-image-0.3.1-ffmpeg-1.patch b/media-plugins/vdr-image/files/vdr-image-0.3.1-ffmpeg-1.patch
new file mode 100644
index 000000000000..78fd1d384435
--- /dev/null
+++ b/media-plugins/vdr-image/files/vdr-image-0.3.1-ffmpeg-1.patch
@@ -0,0 +1,40 @@
+diff -urN image-0.3.1.old/liboutput/encode.c image-0.3.1/liboutput/encode.c
+--- image-0.3.1.old/liboutput/encode.c 2013-06-17 21:23:23.308430203 +0200
++++ image-0.3.1/liboutput/encode.c 2013-06-17 21:27:37.126421173 +0200
+@@ -49,7 +49,6 @@
+
+ bool cEncode::Register()
+ {
+- avcodec_init();
+ #if 0
+ // XXX to resolv: dosen't work with osdpip
+ register_avcodec(&mpeg2video_encoder);
+@@ -100,7 +99,7 @@
+ AVCodecContext *pAVCC = NULL;
+ AVFrame *pAVF = NULL;
+
+- pAVCC = avcodec_alloc_context();
++ pAVCC = avcodec_alloc_context3(NULL);
+ if (! pAVCC)
+ {
+ esyslog("imageplugin: Failed to alloc memory for AVCodecContext.");
+@@ -116,7 +115,7 @@
+ {
+ SetupEncodingParameters(pAVCC);
+
+- if (avcodec_open(pAVCC, m_pavCodec) < 0)
++ if (avcodec_open2(pAVCC, m_pavCodec, NULL) < 0)
+ {
+ esyslog("imageplugin: Couldn't open Codec.");
+ }
+diff -urN image-0.3.1.old/liboutput/encode.h image-0.3.1/liboutput/encode.h
+--- image-0.3.1.old/liboutput/encode.h 2013-06-17 21:23:23.308430203 +0200
++++ image-0.3.1/liboutput/encode.h 2013-06-17 21:27:37.127421173 +0200
+@@ -14,6 +14,7 @@
+
+ extern "C" {
+ #include <libavcodec/avcodec.h>
++#include <libavutil/mem.h>
+ }
+
+ #include "../setup-image.h"
diff --git a/media-plugins/vdr-image/files/vdr-image-0.3.1-gentoo.diff b/media-plugins/vdr-image/files/vdr-image-0.3.1-gentoo.diff
new file mode 100644
index 000000000000..11479f2fc8a2
--- /dev/null
+++ b/media-plugins/vdr-image/files/vdr-image-0.3.1-gentoo.diff
@@ -0,0 +1,24 @@
+diff -Naur image-0.2.7.26.orig/examples/imagecmds.conf image-0.2.7.26/examples/imagecmds.conf
+--- image-0.2.7.26.orig/examples/imagecmds.conf 2008-10-25 23:48:18.000000000 +0200
++++ image-0.2.7.26/examples/imagecmds.conf 2008-10-25 23:50:53.000000000 +0200
+@@ -20,3 +20,5 @@
+ Rotate JPEG picture lossless by 90 degrees to the right : jpegtran -rotate 90 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+ Rotate JPEG picture lossless by 90 degrees to the left : jpegtran -rotate 270 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+ Delete picture ?: rm -f %s
++Change burn template : echo ln -fs '%s' '/usr/share/vdr/burn/menu-bg.png' | /bin/bash
++Change burn template ( Button ) : echo ln -fs '%s' '/usr/share/vdr/burn/menu-button.png' | /bin/bash
+\ Kein Zeilenumbruch am Dateiende.
+diff -Naur image-0.2.7.26.orig/examples/imagecmds.conf.DE image-0.2.7.26/examples/imagecmds.conf.DE
+--- image-0.2.7.26.orig/examples/imagecmds.conf.DE 2008-10-25 23:48:18.000000000 +0200
++++ image-0.2.7.26/examples/imagecmds.conf.DE 2008-10-25 23:55:49.000000000 +0200
+@@ -11,6 +11,8 @@
+ Informationen über das Bild : identify -verbose
+ Größe des Bildes : du -chs %s
+ Exif Informationen des JPEG-Bildes ausgeben : jpegtopnm -dumpexif %s >/dev/null 2> $CONVERT_TEMPDIR/exif.tmp && cat $CONVERT_TEMPDIR/exif.tmp && rm -f $CONVERT_TEMPDIR/exif.tmp
+-Rotatiere JPEG Bildes verlustlos um 90° nach Rechts : jpegtran -rotate 90 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+-Rotatiere JPEG Bildes verlustlos um 90° nach Links : jpegtran -rotate 270 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
++Rotiere JPEG Bildes verlustlos um 90° nach Rechts : jpegtran -rotate 90 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
++Rotiere JPEG Bildes verlustlos um 90° nach Links : jpegtran -rotate 270 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+ Lösche Bild ?: rm -f %s
++Hintergrund vdr-burn ändern : echo ln -fs '%s' '/usr/share/vdr/burn/menu-bg.png' | /bin/bash
++Button vdr-burn ändern : echo ln -fs '%s' '/usr/share/vdr/burn/menu-button.png' | /bin/bash
diff --git a/media-plugins/vdr-image/files/vdr-image-0.4.0-gentoo.diff b/media-plugins/vdr-image/files/vdr-image-0.4.0-gentoo.diff
new file mode 100644
index 000000000000..11479f2fc8a2
--- /dev/null
+++ b/media-plugins/vdr-image/files/vdr-image-0.4.0-gentoo.diff
@@ -0,0 +1,24 @@
+diff -Naur image-0.2.7.26.orig/examples/imagecmds.conf image-0.2.7.26/examples/imagecmds.conf
+--- image-0.2.7.26.orig/examples/imagecmds.conf 2008-10-25 23:48:18.000000000 +0200
++++ image-0.2.7.26/examples/imagecmds.conf 2008-10-25 23:50:53.000000000 +0200
+@@ -20,3 +20,5 @@
+ Rotate JPEG picture lossless by 90 degrees to the right : jpegtran -rotate 90 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+ Rotate JPEG picture lossless by 90 degrees to the left : jpegtran -rotate 270 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+ Delete picture ?: rm -f %s
++Change burn template : echo ln -fs '%s' '/usr/share/vdr/burn/menu-bg.png' | /bin/bash
++Change burn template ( Button ) : echo ln -fs '%s' '/usr/share/vdr/burn/menu-button.png' | /bin/bash
+\ Kein Zeilenumbruch am Dateiende.
+diff -Naur image-0.2.7.26.orig/examples/imagecmds.conf.DE image-0.2.7.26/examples/imagecmds.conf.DE
+--- image-0.2.7.26.orig/examples/imagecmds.conf.DE 2008-10-25 23:48:18.000000000 +0200
++++ image-0.2.7.26/examples/imagecmds.conf.DE 2008-10-25 23:55:49.000000000 +0200
+@@ -11,6 +11,8 @@
+ Informationen über das Bild : identify -verbose
+ Größe des Bildes : du -chs %s
+ Exif Informationen des JPEG-Bildes ausgeben : jpegtopnm -dumpexif %s >/dev/null 2> $CONVERT_TEMPDIR/exif.tmp && cat $CONVERT_TEMPDIR/exif.tmp && rm -f $CONVERT_TEMPDIR/exif.tmp
+-Rotatiere JPEG Bildes verlustlos um 90° nach Rechts : jpegtran -rotate 90 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+-Rotatiere JPEG Bildes verlustlos um 90° nach Links : jpegtran -rotate 270 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
++Rotiere JPEG Bildes verlustlos um 90° nach Rechts : jpegtran -rotate 90 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
++Rotiere JPEG Bildes verlustlos um 90° nach Links : jpegtran -rotate 270 %s > $CONVERT_TEMPDIR/tmp.jpg && mv $CONVERT_TEMPDIR/tmp.jpg %s
+ Lösche Bild ?: rm -f %s
++Hintergrund vdr-burn ändern : echo ln -fs '%s' '/usr/share/vdr/burn/menu-bg.png' | /bin/bash
++Button vdr-burn ändern : echo ln -fs '%s' '/usr/share/vdr/burn/menu-button.png' | /bin/bash
diff --git a/media-plugins/vdr-image/metadata.xml b/media-plugins/vdr-image/metadata.xml
new file mode 100644
index 000000000000..e820fe1a8995
--- /dev/null
+++ b/media-plugins/vdr-image/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ <description>
+ Please contacts maintainer before you something change.
+ </description>
+ </maintainer>
+ <longdescription>
+ VDR Plugin to show pictures on TV
+ </longdescription>
+</pkgmetadata>
diff --git a/media-plugins/vdr-image/vdr-image-0.3.1.ebuild b/media-plugins/vdr-image/vdr-image-0.3.1.ebuild
new file mode 100644
index 000000000000..228901edda54
--- /dev/null
+++ b/media-plugins/vdr-image/vdr-image-0.3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vdr-plugin-2 flag-o-matic
+
+VERSION="679" #every bump, new version
+
+DESCRIPTION="VDR plugin: display of digital images, like jpeg, tiff, png, bmp"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-image"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="exif"
+
+COMMON_DEPEND=">=media-video/vdr-1.5.8
+ >=virtual/ffmpeg-0.10
+ >=media-libs/netpbm-10.0
+ exif? ( media-libs/libexif )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ >=media-tv/gentoo-vdr-scripts-0.2.2"
+
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.3.0.sh"
+BUILD_PARAMS="-j1"
+
+src_prepare() {
+ # remove empty translation file
+ rm "${S}"/po/{cs_CZ,da_DK,et_EE,hr_HR,hu_HU,nn_NO,pl_PL,ro_RO}.po
+
+ vdr-plugin-2_src_prepare
+
+ epatch "${FILESDIR}/${P}-gentoo.diff" \
+ "${FILESDIR}/${P}-ffmpeg-1.patch"
+
+ use !exif && sed -i "s:#WITHOUT_LIBEXIF:WITHOUT_LIBEXIF:" Makefile
+
+ if has_version "<=virtual/ffmpeg-0.4.9_p20061016"; then
+ BUILD_PARAMS="${BUILD_PARAMS} WITHOUT_SWSCALER=1"
+ fi
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cppflags -D__STDC_CONSTANT_MACROS
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/imagecmds
+ newins examples/imagecmds.conf imagecmds.example.conf
+ newins examples/imagecmds.conf.DE imagecmds.example.conf.de
+
+ insinto /etc/vdr/plugins/image
+ doins examples/imagesources.conf
+
+ into /usr/share/vdr/image
+ dobin scripts/imageplugin.sh
+ newbin scripts/mount.sh mount-image.sh
+}
diff --git a/media-plugins/vdr-image/vdr-image-0.4.0.ebuild b/media-plugins/vdr-image/vdr-image-0.4.0.ebuild
new file mode 100644
index 000000000000..e32472c395c4
--- /dev/null
+++ b/media-plugins/vdr-image/vdr-image-0.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+VERSION="1325" #every bump, new version
+
+DESCRIPTION="VDR plugin: display of digital images, like jpeg, tiff, png, bmp"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-image"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="exif"
+
+COMMON_DEPEND=">=media-video/vdr-2
+ >=virtual/ffmpeg-9
+ >=media-libs/netpbm-10.0
+ exif? ( media-libs/libexif )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ media-tv/gentoo-vdr-scripts"
+
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.3.0.sh"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ #wrong include
+ sed -e 's:<liboutput/stillimage-player.h>:"liboutput/stillimage-player.h":'\
+ -i player-image.h
+
+ # dangerous warning
+ sed -e "s:mktemp:mkstemp:" -i data-image.c
+
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+
+ # ffmpeg-2.2.12, libav10
+ sed -e "s:avcodec_alloc_frame:av_frame_alloc:" \
+ -e "s:CODEC_ID_MPEG2VIDEO:AV_CODEC_ID_MPEG2VIDEO:" \
+ -i liboutput/encode.c
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/imagecmds
+ newins examples/imagecmds.conf imagecmds.example.conf
+ newins examples/imagecmds.conf.DE imagecmds.example.conf.de
+
+ insinto /etc/vdr/plugins/image
+ doins examples/imagesources.conf
+
+ into /usr/share/vdr/image
+ dobin scripts/imageplugin.sh
+ newbin scripts/mount.sh mount-image.sh
+}