summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-18 02:33:35 +0000
committerSam James <sam@gentoo.org>2024-12-18 02:33:35 +0000
commit31119352ecc8fcdaf2c417aeb62695bafb1e4563 (patch)
tree62e756647ee2b4e743cd74b3e1d4dee1486a0e53 /media-video
parentapp-vim/csv: Keyword 0.31-r2 arm64, #946595 (diff)
downloadgentoo-31119352ecc8fcdaf2c417aeb62695bafb1e4563.tar.gz
gentoo-31119352ecc8fcdaf2c417aeb62695bafb1e4563.tar.bz2
gentoo-31119352ecc8fcdaf2c417aeb62695bafb1e4563.zip
media-video/cheese: fix Modern C issue
Closes: https://bugs.gentoo.org/919087 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cheese/cheese-44.1-r1.ebuild1
-rw-r--r--media-video/cheese/files/cheese-44.1-c99.patch29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-video/cheese/cheese-44.1-r1.ebuild b/media-video/cheese/cheese-44.1-r1.ebuild
index ea48d52effb9..9ecf98d15258 100644
--- a/media-video/cheese/cheese-44.1-r1.ebuild
+++ b/media-video/cheese/cheese-44.1-r1.ebuild
@@ -65,6 +65,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-43.0-buildfix.patch
+ "${FILESDIR}"/${PN}-44.1-c99.patch
)
src_prepare() {
diff --git a/media-video/cheese/files/cheese-44.1-c99.patch b/media-video/cheese/files/cheese-44.1-c99.patch
new file mode 100644
index 000000000000..e2a8b89d0bb4
--- /dev/null
+++ b/media-video/cheese/files/cheese-44.1-c99.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/919087
+https://gitlab.gnome.org/GNOME/cheese/-/merge_requests/70
+
+From d8b8f27730cca948a5e5346b8ed2db0793bb16e7 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 19 Jan 2024 21:31:33 +0100
+Subject: [PATCH] libcheese: Add GtkWidget cast to avoid an
+ incompatible-pointer-types error
+
+This is required for compilation with GCC 14.
+---
+ libcheese/cheese-flash.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libcheese/cheese-flash.c b/libcheese/cheese-flash.c
+index 59959dbd..e4023221 100644
+--- a/libcheese/cheese-flash.c
++++ b/libcheese/cheese-flash.c
+@@ -132,7 +132,7 @@ cheese_flash_set_property (GObject *object,
+ GObject *parent;
+ parent = g_value_get_object (value);
+ if (object != NULL)
+- priv->parent = g_object_ref (parent);
++ priv->parent = GTK_WIDGET (g_object_ref (parent));
+ else
+ priv->parent = NULL;
+ }
+--
+GitLab