summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-12-16 08:11:16 +0200
committerSam James <sam@gentoo.org>2024-12-22 06:20:27 +0000
commit77da9af0ca5db4278b6185be5adee99d016e5bec (patch)
treea76893e6a63041331212ced97e5f5a32482ce26c /media-video
parentsys-apps/sandbox: add 2.41 (diff)
downloadgentoo-77da9af0ca5db4278b6185be5adee99d016e5bec.tar.gz
gentoo-77da9af0ca5db4278b6185be5adee99d016e5bec.tar.bz2
gentoo-77da9af0ca5db4278b6185be5adee99d016e5bec.zip
media-video/handbrake: filter lto and disable build system hardening
* Filter lto due to rampant lto-type-mismatches and ODR violations. * Disable hardening in build system fixing bug #890279. Closes: https://bugs.gentoo.org/878899 Closes: https://bugs.gentoo.org/890279 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/handbrake/handbrake-1.6.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-video/handbrake/handbrake-1.6.1.ebuild b/media-video/handbrake/handbrake-1.6.1.ebuild
index 2fbb8d88ba6b..9cdc3aa1b4a8 100644
--- a/media-video/handbrake/handbrake-1.6.1.ebuild
+++ b/media-video/handbrake/handbrake-1.6.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools edo python-any-r1 toolchain-funcs xdg
+inherit autotools edo flag-o-matic python-any-r1 toolchain-funcs xdg
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/HandBrake/HandBrake.git"
@@ -117,6 +117,10 @@ src_prepare() {
src_configure() {
tc-export AR RANLIB STRIP
+ # ODR violations, lto-type-mismatches
+ # bug #878899
+ filter-lto
+
# Libav was replaced in 1.2 with ffmpeg by default
# but I've elected to not make people change their use flags for AAC
# as its the same code anyway
@@ -125,6 +129,7 @@ src_configure() {
--verbose
--prefix="${EPREFIX}/usr"
--disable-flatpak
+ --no-harden #bug #890279
$(usex !gtk --disable-gtk)
--disable-gtk4
$(usex !gstreamer --disable-gst)