summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-10-25 14:54:35 +0000
committerYixun Lan <dlan@gentoo.org>2023-10-25 14:54:35 +0000
commit2c82c15a5dce2d62da32bb5933ff331614415bc7 (patch)
tree90586b5db5fa30f4ef364e951b3dd9c510a41d6e /net-ftp
parentnet-im/slack: drop 4.34.120 (diff)
downloadgentoo-2c82c15a5dce2d62da32bb5933ff331614415bc7.tar.gz
gentoo-2c82c15a5dce2d62da32bb5933ff331614415bc7.tar.bz2
gentoo-2c82c15a5dce2d62da32bb5933ff331614415bc7.zip
net-ftp/filezilla: add 3.66.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.66.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index e33ebb2c7ee4..d38ad8f7dbce 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -1,3 +1,4 @@
DIST FileZilla_3.61.0_src.tar.bz2 4939127 BLAKE2B 2c2096b7cb49223b02bea7ae363dde7b58eea4da3fbe62a228edcc6e82c0909e28ff20b6cf909ac7b36209308c66b99faf7c1c4fd571ecd9248c2c3f905c2e85 SHA512 97469bc038eab32f526859ae5db58eeef6f1a8128f67bc653b6b3707b1aa7c9771ef5caa780daa4d11d20d4e7ed8e5df24ef8bd70ee2353f80d77d5410cfa722
DIST FileZilla_3.64.0_src.tar.xz 4041200 BLAKE2B 38e9cec621573ff541183256943d055731f2acad95ab60f771e27b5eed6f0e447c8bf4cdf38c2322a340cd5c4a55ffb5a6b75b0de1bfdc0f8003b8aaaed900a1 SHA512 4c4ab1969613e789999bf634d62b612f21be5e221b969941c8097b7cb3525b089f4dd846e6489a3e66df7671732445e7fb8f77fc8d59cb34a78044136a3d2a99
DIST FileZilla_3.65.0_src.tar.xz 4055316 BLAKE2B 4f702de98baeddda76ba0f3eaa5a06b49e863785980c8a57b84fdf7d3ce49f40b0ae123806c5e76693f19424696daf9ee044813c60bc4ec4216d19f2eccacf48 SHA512 8fb2862eaa7aa4331a095e67335f8e2805936f4866c49f617bdfb819638ecdcbc94e15e8810d90c2eb56e04f0100b8deeb5b691a45012896963ea4ba59644d04
+DIST FileZilla_3.66.0_src.tar.xz 4055872 BLAKE2B b6a66b156d14d012098d63e4bc91bbe3ed9d3b271774f4a169b2c240da67556f52a57b022852942ff3ab068ff4cfbfcc94f2b9681ad9c7cb7dadc362dc22afc0 SHA512 8772987ed0772cb23f2ff15f7a9d8b24d9086b6f24d83c9aa430cbbb7c3e3b8fe209116ae590836e708db1a985539d214cd219413485823a7cc031462e20326d
diff --git a/net-ftp/filezilla/filezilla-3.66.0.ebuild b/net-ftp/filezilla/filezilla-3.66.0.ebuild
new file mode 100644
index 000000000000..489c5e4ccac5
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.66.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+
+inherit autotools wxwidgets xdg
+
+MY_PV="${PV/_/-}"
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="dbus nls test"
+RESTRICT="!test? ( test )"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND="
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/boost-1.76.0:=
+ >=dev-libs/libfilezilla-0.45.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cppunit-1.13.0 )"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+ "${FILESDIR}"/${PN}-3.52.2-slibtool.patch
+ "${FILESDIR}"/${PN}-3.60.1-desktop.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}