summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/gg-transport
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/gg-transport')
-rw-r--r--net-im/gg-transport/Manifest1
-rw-r--r--net-im/gg-transport/files/jggtrans-2.2.2-r120
-rw-r--r--net-im/gg-transport/files/jggtrans-2.2.420
-rw-r--r--net-im/gg-transport/gg-transport-2.2.4.ebuild46
-rw-r--r--net-im/gg-transport/metadata.xml12
5 files changed, 99 insertions, 0 deletions
diff --git a/net-im/gg-transport/Manifest b/net-im/gg-transport/Manifest
new file mode 100644
index 000000000000..3df74610adcb
--- /dev/null
+++ b/net-im/gg-transport/Manifest
@@ -0,0 +1 @@
+DIST jggtrans-2.2.4.tar.gz 796625 SHA256 678db2bef8e867889715663188f6ac785c7bf6e1bd0840a000f0a76b28892830
diff --git a/net-im/gg-transport/files/jggtrans-2.2.2-r1 b/net-im/gg-transport/files/jggtrans-2.2.2-r1
new file mode 100644
index 000000000000..7e38a40b2231
--- /dev/null
+++ b/net-im/gg-transport/files/jggtrans-2.2.2-r1
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after net jabber-server
+}
+
+start() {
+ ebegin "Starting Jabber GG Transport"
+ start-stop-daemon --start --user jabber --group jabber --exec /usr/sbin/jggtrans -- -u jabber -g jabber /etc/jabber/jggtrans.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Jabber GG Transport"
+ start-stop-daemon --stop --pidfile /var/run/jabber/jggtrans.pid
+ eend $?
+}
diff --git a/net-im/gg-transport/files/jggtrans-2.2.4 b/net-im/gg-transport/files/jggtrans-2.2.4
new file mode 100644
index 000000000000..7e38a40b2231
--- /dev/null
+++ b/net-im/gg-transport/files/jggtrans-2.2.4
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after net jabber-server
+}
+
+start() {
+ ebegin "Starting Jabber GG Transport"
+ start-stop-daemon --start --user jabber --group jabber --exec /usr/sbin/jggtrans -- -u jabber -g jabber /etc/jabber/jggtrans.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Jabber GG Transport"
+ start-stop-daemon --stop --pidfile /var/run/jabber/jggtrans.pid
+ eend $?
+}
diff --git a/net-im/gg-transport/gg-transport-2.2.4.ebuild b/net-im/gg-transport/gg-transport-2.2.4.ebuild
new file mode 100644
index 000000000000..b29c5438b0f6
--- /dev/null
+++ b/net-im/gg-transport/gg-transport-2.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Gadu-Gadu transport for Jabber"
+HOMEPAGE="https://github.com/Jajcus/jggtrans"
+SRC_URI="mirror://github/Jajcus/jggtrans/jggtrans-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=net-im/jabber-base-0.01
+ >=dev-libs/glib-2.6.4
+ net-dns/libidn
+ >=net-libs/libgadu-1.9.0_rc3
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/jggtrans-${PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ keepdir /var/spool/jabber/gg
+ keepdir /var/run/jabber
+ keepdir /var/log/jabber
+ fowners jabber:jabber /var/spool/jabber/gg
+ fowners jabber:jabber /var/run/jabber
+ fowners jabber:jabber /var/log/jabber
+
+ newinitd "${FILESDIR}/jggtrans-${PVR}" jggtrans
+
+ insinto /etc/jabber
+ doins jggtrans.xml
+
+ sed -i \
+ -e 's,/var/lib/jabber/spool/gg.localhost/,/var/spool/jabber/gg/,' \
+ -e 's,/var/lib/jabber/ggtrans.pid,/var/run/jabber/jggtrans.pid,' \
+ -e 's,/tmp/ggtrans.log,/var/log/jabber/jggtrans.log,' \
+ "${D}/etc/jabber/jggtrans.xml" || die "sed failed"
+
+ dodoc AUTHORS ChangeLog README README.Pl NEWS
+}
diff --git a/net-im/gg-transport/metadata.xml b/net-im/gg-transport/metadata.xml
new file mode 100644
index 000000000000..e30841e388bf
--- /dev/null
+++ b/net-im/gg-transport/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <longdescription>
+ Gadu-Gadu is a IM network vary famous in Poland, this package will
+ enable your jabber server to talk to that network.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Jajcus/jggtrans</remote-id>
+ </upstream>
+</pkgmetadata>