summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/ktp-common-internals
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/ktp-common-internals')
-rw-r--r--net-im/ktp-common-internals/Manifest1
-rw-r--r--net-im/ktp-common-internals/ktp-common-internals-0.9.0.ebuild48
-rw-r--r--net-im/ktp-common-internals/metadata.xml8
3 files changed, 57 insertions, 0 deletions
diff --git a/net-im/ktp-common-internals/Manifest b/net-im/ktp-common-internals/Manifest
new file mode 100644
index 000000000000..7cce6df25aa6
--- /dev/null
+++ b/net-im/ktp-common-internals/Manifest
@@ -0,0 +1 @@
+DIST ktp-common-internals-0.9.0.tar.bz2 439404 SHA256 b358d134345225dacddffb2e61177a4819093c55f2ca15c4c3481e1a6e9f9443 SHA512 65ee4330d05ff91183935767069927978ff973152428ccaa88fd1a77cdef8ad1d6cb939276061b63fcfbecc9b051e83a603f07c327248dc2c28dbfa674fb226b WHIRLPOOL 8f5d22eff2a3c01d5b84f29d5392751574499b5f47d5bc6c81d5d22d2bb63f0b56d7ba135b34db9517465574a046b15da38887559e9d1147391b239c0a0ec3f1
diff --git a/net-im/ktp-common-internals/ktp-common-internals-0.9.0.ebuild b/net-im/ktp-common-internals/ktp-common-internals-0.9.0.ebuild
new file mode 100644
index 000000000000..afa5cb821687
--- /dev/null
+++ b/net-im/ktp-common-internals/ktp-common-internals-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el es et fi fr ga gl hu ia it ja kk ko
+lt mr nb nds nl pl pt pt_BR ro ru sk sl sr sr@ijekavian sr@ijekavianlatin
+sr@latin sv uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Telepathy common library"
+HOMEPAGE="http://community.kde.org/Real-Time_Communication_and_Collaboration"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/stable/kde-telepathy/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+IUSE="debug otr semantic-desktop"
+
+DEPEND="
+ >=net-libs/telepathy-qt-0.9.5[qt4]
+ >=net-libs/telepathy-logger-qt-0.5.80:0
+ otr? (
+ dev-libs/libgcrypt:=
+ >=net-libs/libotr-4.0.0
+ )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs)
+ >=net-libs/libkpeople-0.3.0:=
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package otr Libgcrypt)
+ $(cmake-utils_use_find_package otr LibOTR)
+ $(cmake-utils_use_find_package semantic-desktop KPeople)
+ $(cmake-utils_use_find_package semantic-desktop KdepimLibs)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/net-im/ktp-common-internals/metadata.xml b/net-im/ktp-common-internals/metadata.xml
new file mode 100644
index 000000000000..0defe784bf07
--- /dev/null
+++ b/net-im/ktp-common-internals/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="otr">Enable support for encrypted conversations using Off-The-Records messaging</flag>
+ </use>
+</pkgmetadata>