summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-11-22 21:25:30 +0100
committerDavid Seifert <soap@gentoo.org>2023-11-22 21:25:30 +0100
commit16f48fc0b921531ae03e4f7ab8d4ebed081bf00a (patch)
tree60be8b636876f4d4b490214cad0c5ae64af8c0fe /net-im/skypeforlinux
parentapp-editors/sublime-text: add 4_p4166 (diff)
downloadgentoo-16f48fc0b921531ae03e4f7ab8d4ebed081bf00a.tar.gz
gentoo-16f48fc0b921531ae03e4f7ab8d4ebed081bf00a.tar.bz2
gentoo-16f48fc0b921531ae03e4f7ab8d4ebed081bf00a.zip
net-im/skypeforlinux: add 8.108.0.205
Closes: https://bugs.gentoo.org/917314 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.108.0.205.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 06a019f68149..847bf2e1aa49 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -2,3 +2,4 @@ DIST skypeforlinux_8.100.0.203_amd64.deb 126350190 BLAKE2B aee5ed36e4c9a63d5eaf5
DIST skypeforlinux_8.102.0.211_amd64.deb 126682902 BLAKE2B 2a03846202f132656b95594202620375839f1915678483b57deab4a9fa2f4e3224c45529db74cc44e6a53e239662e55f4fda13695b331c5d35cbbb2ebca2b35d SHA512 348c38e880f07047a2b279314c66937db0c83253c07db5735852f9f72d4f6a70e884a0f5921abdb38251f85dabb4e569c1429a45df260ca7a717afdbc16f5955
DIST skypeforlinux_8.103.0.208_amd64.deb 121258812 BLAKE2B 9cceda7cd818dbecb88160cd121f778c99452bd9848f890d2b1080b6f12e861a25e0c78170002d98d8f21b870475019e51a369307af1f128642949850c864568 SHA512 be821fd2c3fbc0fb00551c0c260813e01818d3ebd74481949e9398c4d52a4d7b88d96e971b9d507caa12ecfdb5fc4e436ce2c47c2cd9d14525543ad8f890d671
DIST skypeforlinux_8.105.0.208_amd64.deb 121428072 BLAKE2B bea3227647fc9549fc2ec64e4b229bcfff98858306483209a215516cacc25d60f47accb5186da943a47015d94ba290c2794157c4d423a9c1cd5228475c80d623 SHA512 e88cc2791e79c9af31e925ce68034d8f5cacc77990ed279f7a19ef5ef6e258b3f3c6b74d0a407ce3bee477e1080085819f494d8f83ba2ca82e5d87a81c033155
+DIST skypeforlinux_8.108.0.205_amd64.deb 121989382 BLAKE2B 9881f81d46e8b89e737a78b8671fbdc0739eb349751791539531e0191a44512d2130371b40e302c6dccc3d15d3b6d6ddb006546732a1d39fca386bb3869bb57f SHA512 2d84ea37635f8b725f4654cf163202a372423eb6695af66b8e7cdd52f8780f6360571f67d780f11a4df08b3f0e99349b9e0253f3887d0821c79183ab0adc446b
diff --git a/net-im/skypeforlinux/skypeforlinux-8.108.0.205.ebuild b/net-im/skypeforlinux/skypeforlinux-8.108.0.205.ebuild
new file mode 100644
index 000000000000..a96df6bc8f2e
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.108.0.205.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils unpacker multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/deb/pool/main/s/skypeforlinux/${PN}_${PV}_amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="selinux"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ sys-libs/glibc
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+ selinux? ( sec-policy/selinux-skype )
+"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}