summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-19 22:43:18 +0100
committerSam James <sam@gentoo.org>2023-04-22 15:25:59 +0100
commitb64d7d797b322a0405c9de08cd832d0ebd03210c (patch)
treeb3565df4dffa81c6a7cd89a16a7a967b9a20b85c /net-im/skypeforlinux
parentapp-office/calligra: USE cmake FindGSL module instead of bundled one (diff)
downloadgentoo-b64d7d797b322a0405c9de08cd832d0ebd03210c.tar.gz
gentoo-b64d7d797b322a0405c9de08cd832d0ebd03210c.tar.bz2
gentoo-b64d7d797b322a0405c9de08cd832d0ebd03210c.zip
net-im/skypeforlinux: use .deb build as source due to checksum errors with RPM build
[sam: The RPM seems to be being re-signed every 5 minutes. Switch to the .deb which doesn't have this problem.] Closes: https://bugs.gentoo.org/904352 Signed-off-by: Ghiunhan Mamut <venerix@redcorelinux.org> Closes: https://github.com/gentoo/gentoo/pull/30657 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest2
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.96.0.408.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 3f9949865a1c..68f6ca210471 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,4 +1,4 @@
DIST skypeforlinux_8.94.0.428-1.x86_64.rpm 126374668 BLAKE2B e90c5207c1ec0d2835158fd9a7382d8c412ab4f880200b4570195d1453f81b6a5aea26edb49eac153dd680a270fd8ef4f43b4c7a4bf1abd802f2cacef18256c3 SHA512 6623384ee97274cca43fa1013eeab14508e47b4b649b4b633025f658116147c3a4cce9eb584ed6b4f51e5dcb7e323b61c01c7fbd2bdd7a33224131941bb8a727
DIST skypeforlinux_8.95.0.408-1.x86_64.rpm 126523292 BLAKE2B 5e6018b7a2aef8a8cf4311cb50475af7f7799e93d2a1e8b4755428b0ce670819db9c106ac830121b75543c03fed7fc08c910544eb7d3dfb57c11fd7f30df9319 SHA512 c4acdb94e962753e61386e0c0ff18e217a395d5f919ed70ef83e655ca5bd7758f53391dbe977f0b0ffc27c5ea7ec465bf168fec557de3040db425cc365e8eff7
DIST skypeforlinux_8.96.0.207-1.x86_64.rpm 124580688 BLAKE2B 8bd2dfecee6730d4aeb49bef0e08fd1fd17aecf31a8cd81b5d0ba3d4a8bc6808bd6e08d7c91d39aa46982502b23c8e37c5f4ce2ae87da963cc0df8a8b8ed430d SHA512 27406615892a12a390d47e2a2087149c29a195e942d9fb1748ad1f7cb39012fdad0836b01c4bfe6e690e1a27f67ccdd6d0da2f4baa3cf6567733d95b5a35be17
-DIST skypeforlinux_8.96.0.408-1.x86_64.rpm 124598879 BLAKE2B b3dcce3cbe8e51ebbe0f6478e8934890fae8c34051ebb2ba87b809353db69b50d7005db621cb198e960186f08eb82e4339f936423c65630c46c6bd9619c90ba3 SHA512 9d2c77157cba9db33182e5083f44009d06e9cb951bdee43d686e1029590ef13ac604fcf15b1b6899ab1f4bc8ef04c90509231fc3d7ad0ca500963affeb09eb12
+DIST skypeforlinux_8.96.0.408_amd64.deb 124565400 BLAKE2B 56f8e20c3f192322267afb308fb211bb1af13f144c19e4d42ea2df3ac6a4f1648f47738ca9f1f44ed13f8f20b796726ffc41d9a658431bbd12ecb92579ae3d04 SHA512 b7aa70435c6d0f2b821a8f33b5b33ef6204dafe1467f92024389498c013260ea86649928d93c10ad3a29ffe5b277f0c57b2732d4ed6efe93568b7053ecdfbf44
diff --git a/net-im/skypeforlinux/skypeforlinux-8.96.0.408.ebuild b/net-im/skypeforlinux/skypeforlinux-8.96.0.408.ebuild
index 4dc00a3d1aec..aa8b927e61ba 100644
--- a/net-im/skypeforlinux/skypeforlinux-8.96.0.408.ebuild
+++ b/net-im/skypeforlinux/skypeforlinux-8.96.0.408.ebuild
@@ -5,11 +5,11 @@ EAPI=8
MULTILIB_COMPAT=( abi_x86_64 )
-inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+inherit chromium-2 desktop pax-utils unpacker multilib-build xdg
DESCRIPTION="Instant messaging client, with support for audio and video"
HOMEPAGE="https://www.skype.com/"
-SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+SRC_URI="https://repo.skype.com/deb/pool/main/s/skypeforlinux/${PN}_${PV}_amd64.deb"
S="${WORKDIR}"
LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
@@ -59,7 +59,7 @@ pkg_setup() {
}
src_unpack() {
- rpm_src_unpack ${A}
+ unpack_deb ${A}
}
src_prepare() {