summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ifenslave
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ifenslave')
-rw-r--r--net-misc/ifenslave/Manifest2
-rw-r--r--net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild55
-rw-r--r--net-misc/ifenslave/metadata.xml11
3 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/ifenslave/Manifest b/net-misc/ifenslave/Manifest
new file mode 100644
index 000000000000..e68f96063691
--- /dev/null
+++ b/net-misc/ifenslave/Manifest
@@ -0,0 +1,2 @@
+DIST ifenslave-2.6_1.1.0-17.debian.tar.gz 9406 SHA256 5d34e36dcdd83ec9615e2cb51951888939179be6350eab1cc6c978b0ff662a75 SHA512 90773620e15883f39f3bf3039133385d21d597f2051b81d98f96a2d7b9d7f69bf8f00bab0ffa2ad0fde5b2f4b83cac683b24925f26b6f014c0fa06f6d1023de5 WHIRLPOOL 5ab7bbe48c33efbad002270c704f2ff7149ff435b748a5aa6e1476dbf5ee14a23f71225fcb1f2da21e40b38897a58678d94be72828aa30fe8cb0dcd6c7f5e9ff
+DIST ifenslave-2.6_1.1.0.orig.tar.gz 8002 SHA256 7917bf34de80a2492eb225adf9168c83a4854ac8a008ed0fd5b3fd147ccd3041 SHA512 65d9b632e88c63dc4c2bae752a4561cc7f315278b301c906c6f023934d6af8cdb894d06e1582d831bf0ac88f8d27751115b4f2e8bea6cbb89a705e4bc04068c7 WHIRLPOOL badadeb1377ec29e8be108b4365137724473593f15bab8c57550b450889c6a41b5c5be2dc9c281c1cae9e2ef02dbbddab9d1bd716036e366b3ae5a203aa4e2b4
diff --git a/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild b/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild
new file mode 100644
index 000000000000..3d652b7bc3f1
--- /dev/null
+++ b/net-misc/ifenslave/ifenslave-1.1.0-r6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_PN="ifenslave-2.6" # this is NOT an error
+DEBIAN_PV="17"
+DEBIANPKG_TARBALL="${MY_PN}_${PV}.orig.tar.gz"
+DEBIANPKG_PATCH="${MY_PN}_${PV}-${DEBIAN_PV}.debian.tar.gz"
+DEBIANPKG_BASE="mirror://debian/pool/main/${MY_PN:0:1}/${MY_PN}"
+
+inherit toolchain-funcs linux-info
+
+DESCRIPTION="Attach and detach slave interfaces to a bonding device"
+HOMEPAGE="http://sf.net/projects/bonding/"
+SRC_URI="${DEBIANPKG_BASE}/${DEBIANPKG_TARBALL}
+ ${DEBIANPKG_BASE}/${DEBIANPKG_PATCH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gcc
+ >=sys-kernel/linux-headers-2.4.22
+ ${RDEPEND}"
+
+CONFIG_CHECK="~BONDING"
+WARNING_BONDING="CONFIG_BONDING is required to get bond devices in the kernel"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -o ${PN} || die "Failed to compile!"
+}
+
+src_install() {
+ into /
+ dosbin ${PN}
+ into
+
+ # there really is no better documentation than the sourcecode :-)
+ dodoc ${PN}.c
+
+ doman "${WORKDIR}/debian/${PN}.8"
+}
+
+pkg_preinst() {
+ if [[ -f /etc/modules.d/bond ]] || [[ -f /etc/modprobe.d/bond ]]; then
+ elog "You may want to remove /etc/modules.d/bond and/or /etc/modprobe.d/bond"
+ elog "because it likely causes some deprecation warnings like:"
+ elog "Loading kernel module for a network device with CAP_SYS_MODULE (deprecated). Use CAP_NET_ADMIN and alias netdev-bond0 instead"
+ elog "It may also cause unexpected behaviour."
+ fi
+}
diff --git a/net-misc/ifenslave/metadata.xml b/net-misc/ifenslave/metadata.xml
new file mode 100644
index 000000000000..75c5a9141f49
--- /dev/null
+++ b/net-misc/ifenslave/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>