summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 19:34:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 19:40:32 -0400
commit60495ef59a53394886aa59c3590494f384ada7a2 (patch)
tree1e7e0a443c673c3cc496084cb19ff68d494675cd /net-misc/yt-dlp
parentapp-xemacs/ebuild-mode: Stabilize 1.75-r1 ALLARCHES, #940342 (diff)
downloadgentoo-60495ef59a53394886aa59c3590494f384ada7a2.tar.gz
gentoo-60495ef59a53394886aa59c3590494f384ada7a2.tar.bz2
gentoo-60495ef59a53394886aa59c3590494f384ada7a2.zip
net-misc/yt-dlp: add 2024.09.27
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 32f1cae4674d..119490707992 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2024.08.06.tar.gz 5710396 BLAKE2B ba657ddd054fc814adfc9644378ab51e50f980a8ce9d9589d0e69d4242fc68a22314a230135c54737a1b453d853d811a48d1737b05c2e04d3494ca580a6937b0 SHA512 5db3ceeb217148755e31492d490bfeb69879400873274dec4320ce58b49dce9ce93d1e32714d6b7433364780e269087fc55acb94ef4fca0d998c504f2efac41f
+DIST yt-dlp-2024.09.27.tar.gz 5750902 BLAKE2B 22c36dc45fd8f0b059542edf721757d50f4f4df640dfb2415ef0143e287e7ae6535e868705faa738ad1be3dd07bede85660ecc47f133c2eba2d13abc40e99c71 SHA512 9440eafd8c68bc4cc9d34edf616dbb34e0810556d21bd2276198359e653d155586cc398ebedc1088fb238dae78f62f2443463e4a63f90b323aec4ca53d3211e1
diff --git a/net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild b/net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild
new file mode 100644
index 000000000000..b41167626f69
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}