summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-05-03 14:22:16 +0800
committerIan Delaney <idella4@gentoo.org>2016-05-03 14:45:22 +0800
commit0bbae9c59e3c60db46516fb1d1f75a42e30d0335 (patch)
treefcc49952c51d078444a4e9ea1627e38b5cdca418 /net-p2p
parentRevert "net-p2p/classified-ads: v0.10 version bump - Forced update of digests... (diff)
downloadgentoo-0bbae9c59e3c60db46516fb1d1f75a42e30d0335.tar.gz
gentoo-0bbae9c59e3c60db46516fb1d1f75a42e30d0335.tar.bz2
gentoo-0bbae9c59e3c60db46516fb1d1f75a42e30d0335.zip
Revert "net-p2p/classified-ads: v0.10 version bump. Changes dependency qt4->qt5, has EAPI=6."
This reverts commit 37e876bc29f2c811383c3d0fdc8d7478ecab9578.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/classified-ads/classified-ads-0.10.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/net-p2p/classified-ads/classified-ads-0.10.ebuild b/net-p2p/classified-ads/classified-ads-0.10.ebuild
index d7f75da81b02..a792705205c9 100644
--- a/net-p2p/classified-ads/classified-ads-0.10.ebuild
+++ b/net-p2p/classified-ads/classified-ads-0.10.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
PLOCALES="en fi sv da uk"
PLOCALE_BACKUP="en"
-inherit qmake-utils virtualx vcs-snapshot
+inherit qt4-r2 qmake-utils virtualx vcs-snapshot
COMMIT_ID="cd0652c52f86f6284b793f26e5362bc8fb8a7118"
DESCRIPTION="Program for displaying classified advertisement items"
@@ -21,40 +21,37 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug doc test"
RDEPEND="dev-libs/openssl:0
+ dev-libs/qjson
>=net-libs/libnatpmp-20130911
<=net-libs/libnatpmp-20140401-r1
>=net-libs/miniupnpc-1.8
sys-apps/file
sys-devel/gettext
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtwidgets:5
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtsql:4[sqlite]
+ dev-qt/qtgui:4[debug?]
dev-qt/qt-mobility[multimedia]
- dev-qt/qtprintsupport:5
+ dev-qt/qtmultimedia:4
media-libs/opus"
DEPEND="${RDEPEND}
- dev-qt/qttest:5
+ dev-qt/qttest:4
sys-devel/gdb:0
doc? ( app-doc/doxygen[dot] )
test? ( dev-libs/libgcrypt:0
- ${VIRTUALX_DEPEND} )"
+ ${VIRTUALX_DEPEND} )
+ "
src_prepare() {
# preprocessed graphics are unpacked into wrong directory
# so lets move them into correct location:
mv ../classified-ads-graphics-${PV}/* ui/ || die
- # possible patches
- eapply_user
# then just run qmake
- eqmake5
+ qt4-r2_src_prepare
}
src_compile() {
- emake
+ qt4-r2_src_compile
if use doc; then
cd doc || die
doxygen || die
@@ -73,7 +70,8 @@ src_install() {
# virtualx requires a command that returns number, and does not just die:
test_suite() {
cd test || return -1
- eqmake5 || return -2
+ echo qmake
+ "$(qt4_get_bindir)"/qmake || return -2
emake
# test suite will create files under $HOME, set $HOME to point to
# safe location, ideas stolen from