summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-02 04:52:22 +0100
committerSam James <sam@gentoo.org>2022-06-02 04:52:22 +0100
commit358921d99b8990d658471efcd37f9119d599bfae (patch)
treea059f2c20172d5e72b7fb9b7b9b733be7bede3db /net-p2p
parentnet-libs/libtorrent-rasterbar: drop 1.2.14-r1, 2.0.4-r4, 2.0.5-r1 (diff)
downloadgentoo-358921d99b8990d658471efcd37f9119d599bfae.tar.gz
gentoo-358921d99b8990d658471efcd37f9119d599bfae.tar.bz2
gentoo-358921d99b8990d658471efcd37f9119d599bfae.zip
net-p2p/qbittorrent: drop 4.4.2-r2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.4.2-r2.ebuild107
2 files changed, 0 insertions, 108 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 5761fef8d19b..18ec07aba2de 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,3 +1,2 @@
DIST qbittorrent-4.3.9.tar.gz 8510414 BLAKE2B de98aff6d81f43c3ad87f6c5f800a4488e18173fb96713d0a2420cf4d4708c9b1f2f54c8d0aa566e7738b4f94d192aad9f0196a05d43724582ef81833901727f SHA512 ec33f67895fbf47acc2f79d9c9e16db8b96c756cf493b76eb24b90e13a790a709104ea9aa378ee111d8c38b605bed5192b366d1917bbf160b21aa2ae3aacd2d1
-DIST qbittorrent-4.4.2.tar.gz 9197188 BLAKE2B 719ca031b1a5523cd29582d7d57ac48e5d3cfb8b1c62e23f01d116897e7753cda204a0dc401f364860eba750371f41178d87ae6d1f43241506868d90a8bc9e32 SHA512 55656fb5fd282a3ed0e703b9b47ec9733a70cf6242cae956a5b2487ef2aeb88a04bf5d37c8fa88554edf95ab0821b76ebebb53e8fc43dc5889f8c730075d6e26
DIST qbittorrent-4.4.3.1.tar.gz 7736308 BLAKE2B 9177f0c629418a5f9e7f117b7d1f990181ef910193fed9763f2137cbc91c9de07ad96884d57e96782b5a2f6089fe73d3fab0a2f2f54f72dd8c2cec00dd179e5f SHA512 e3d63c4090e27387f4a5524d0daab26eab70f70ef81ad607e9661e128ccccbf33f2d240cd219bbb1fb138d6e78493ce73055d5128bf888e0ad3949922774efba
diff --git a/net-p2p/qbittorrent/qbittorrent-4.4.2-r2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.4.2-r2.ebuild
deleted file mode 100644
index 159cdd733aa3..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-4.4.2-r2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake multibuild systemd xdg
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="https://www.qbittorrent.org
- https://github.com/qbittorrent"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
-else
- SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
- S="${WORKDIR}/qBittorrent-release-${PV}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+dbus +gui webui"
-REQUIRED_USE="dbus? ( gui )
- || ( gui webui )"
-
-RDEPEND="
- >=dev-libs/boost-1.65.0-r1:=
- dev-libs/openssl:=
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5
- dev-qt/qtxml:5
- >=net-libs/libtorrent-rasterbar-1.2.14:=
- sys-libs/zlib
- dbus? ( dev-qt/qtdbus:5 )
- gui? (
- dev-libs/geoip
- dev-qt/qtgui:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- )"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-qt/linguist-tools:5
- virtual/pkgconfig"
-
-DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
-
-src_prepare() {
- MULTIBUILD_VARIANTS=( base )
- use webui && MULTIBUILD_VARIANTS+=( webui )
-
- multibuild_foreach_variant cmake_src_prepare
-}
-
-src_configure() {
- multibuild_src_configure() {
- local mycmakeargs=(
- -DDBUS=$(usex dbus)
-
- # musl lacks execinfo.h
- -DSTACKTRACE=$(usex !elibc_musl)
-
- # We always want to install unit files
- -DSYSTEMD=ON
- -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
-
- # More verbose build logs are preferable for bug reports
- -DVERBOSE_CONFIGURE=ON
-
- # Not yet in ::gentoo
- -DQT6=OFF
-
- # We do these in multibuild, see bug #839531 for why
- # Fedora has to do the same thing.
- -DGUI=$(usex gui)
- )
-
- if [[ ${MULTIBUILD_VARIANT} == webui ]] ; then
- mycmakeargs+=(
- -DGUI=OFF
- -DWEBUI=ON
- )
- else
- mycmakeargs+=( -DWEBUI=OFF )
- fi
-
- cmake_src_configure
- }
-
- multibuild_foreach_variant multibuild_src_configure
-}
-
-src_compile() {
- multibuild_foreach_variant cmake_src_compile
-}
-
-src_install() {
- multibuild_foreach_variant cmake_src_install
-
- if ! use webui ; then
- # No || die deliberately as it doesn't always exist
- rm "${D}/$(systemd_get_systemunitdir)"/qbittorrent-nox*.service
- fi
-
- einstalldocs
-}